summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-embedded/pista/pista-0.70.ebuild')
-rw-r--r--dev-embedded/pista/pista-0.70.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-embedded/pista/pista-0.70.ebuild b/dev-embedded/pista/pista-0.70.ebuild
new file mode 100644
index 000000000000..16881804b8b1
--- /dev/null
+++ b/dev-embedded/pista/pista-0.70.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="Commandline-driven interface to PICSTART+ PIC programmer"
+HOMEPAGE="http://gatling.ikk.sztaki.hu/~kissg/pd/pista/pista.html"
+SRC_URI="ftp://gatling.ikk.sztaki.hu/pub/pic/pista/${P}.tar.gz
+ http://pista.choup.net/pub/pic/pista/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ dev-perl/TermReadKey"
+
+src_compile() {
+ perl Makefile.PL PREFIX=/usr || die "Running Makefile.PL failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake install DESTDIR=${D} || die
+ dodoc README Changes Copyright doc/pista.html
+}