summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-embedded/u-boot-tools')
-rw-r--r--dev-embedded/u-boot-tools/Manifest4
-rw-r--r--dev-embedded/u-boot-tools/files/u-boot-no-config.h.patch92
-rw-r--r--dev-embedded/u-boot-tools/metadata.xml5
-rw-r--r--dev-embedded/u-boot-tools/u-boot-tools-2013.07.ebuild46
-rw-r--r--dev-embedded/u-boot-tools/u-boot-tools-2014.01.ebuild46
-rw-r--r--dev-embedded/u-boot-tools/u-boot-tools-2015.01.ebuild42
-rw-r--r--dev-embedded/u-boot-tools/u-boot-tools-2015.04.ebuild44
7 files changed, 279 insertions, 0 deletions
diff --git a/dev-embedded/u-boot-tools/Manifest b/dev-embedded/u-boot-tools/Manifest
new file mode 100644
index 000000000000..012e9ebc10d4
--- /dev/null
+++ b/dev-embedded/u-boot-tools/Manifest
@@ -0,0 +1,4 @@
+DIST u-boot-2013.07.tar.bz2 10067674 SHA256 2bbd440c1b29928d230604eac372fda5152d3ae23f52b1910c77fc5bf531250b SHA512 5c0725c9c5c7c9101d7ef8eb659aafb513ca5742fbafec55e0b64cd68b3e37520de55f71aebba59bf979b8daef2b0c71645b5ab343b7057d601b3cd6ffc6e763 WHIRLPOOL 41f1a78b6f7af206bb2a6c04be23ad1aceaa4a105ede4794b4a9d6777e3e92ae2014906be30c749cae51ea9d865f7e565185d9baaa0e953b01a053b62621ad66
+DIST u-boot-2014.01.tar.bz2 10180625 SHA256 cdaf8c81583abfa2e73da46cfcf87b0cbd9741d9aa766f3b905376e3652d543d SHA512 c6e4f6f9a2dae1a50b7dd94dad13ef5d0ce440c3f0401de3f0ecf907c8fca0ff183077ec3b2c4da42b0fa9775450b03571725c76dfd2419a4ee7b982c261ccb1 WHIRLPOOL 9964abde477ce54dfe0a0972920e19c6d60209e8a19819c98b955a9a8b23cc57ac8e687d9ced65411eb6ff1ac40121edac154e754b3b5a2f037cf3a7724de374
+DIST u-boot-2015.01.tar.bz2 9982195 SHA256 383051a656ebe11757b17d38a3326387e4a1b0949ca8a9e8ee506bf71dac9fde SHA512 6697c6da5f463bdfa75b8025a2dd302e9cda58ce36bc3252590f11976807aeccc1ca76be93cbc83d3367a7557878516bb57130ffb76197ffd513640c48e18938 WHIRLPOOL 7ed552f0f32d061c1723c42f0230611d6552068765ea3130fe070d1a906da2defafa14a67078ef7feda4ed29857f51a5b47b3595aa7a8eb07bf26778a3517aff
+DIST u-boot-2015.04.tar.bz2 9471487 SHA256 0a1a70df586655f527befa6f12e184e96ed61b126e5a567382321b17200f5d60 SHA512 e50a3d7e44bf588a7cf8e28cdf3342bc38bd1bf55231d579c2501b75386cfff0fbc7a34648d893971e0095510c9d582b7180427832cb78470b4e7af2ce0e3646 WHIRLPOOL dbfd4b13b82505ef94e8b394ba260684ee18c881bd84adfc841194ce6a4b967c8514cedfcac6777045a50b940e3a1882af667e152dc0fc0d3b9254a7dfca89d0
diff --git a/dev-embedded/u-boot-tools/files/u-boot-no-config.h.patch b/dev-embedded/u-boot-tools/files/u-boot-no-config.h.patch
new file mode 100644
index 000000000000..1009ab00f5b2
--- /dev/null
+++ b/dev-embedded/u-boot-tools/files/u-boot-no-config.h.patch
@@ -0,0 +1,92 @@
+This patch has been reverted later on by
+http://git.denx.de/?p=u-boot.git;a=commit;h=e3c52f2b8779469c843eb79282396f1a5ca3fef5
+
+but we still need it to build the tools without having to configure
+a full u-boot environment.
+
+Signed-off-by: Markos Chandras <hwoarang@gentoo.org>
+
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Sat, 10 Nov 2012 19:47:47 +0000 (+0000)
+Subject: fw_env: fix building w/out a config.h
+X-Git-Tag: v2013.01-rc3~19
+X-Git-Url: http://git.denx.de/?p=u-boot.git;a=commitdiff_plain;h=92ace272d06cec1d7f1533bb9edf914fb5845fba;hp=7a546db2ffc6a713fb8009d8246c29da5420f6a7
+
+fw_env: fix building w/out a config.h
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+Acked-by: Peter Korsgaard <jacmet@sunsite.dk>
+---
+
+diff --git a/tools/env/Makefile b/tools/env/Makefile
+index 0e798e0..e6dc5f3 100644
+--- a/tools/env/Makefile
++++ b/tools/env/Makefile
+@@ -26,7 +26,7 @@ include $(TOPDIR)/config.mk
+ HOSTSRCS := $(SRCTREE)/lib/crc32.c fw_env.c fw_env_main.c
+ HOSTSRCS += $(SRCTREE)/lib/ctype.c $(SRCTREE)/lib/linux_string.c
+ HOSTSRCS += $(SRCTREE)/common/env_attr.c $(SRCTREE)/common/env_flags.c
+-HEADERS := fw_env.h $(OBJTREE)/include/config.h
++HEADERS := fw_env.h
+
+ # Compile for a hosted environment on the target
+ HOSTCPPFLAGS = -idirafter $(SRCTREE)/include \
+@@ -36,6 +36,15 @@ HOSTCPPFLAGS = -idirafter $(SRCTREE)/include \
+ -DUSE_HOSTCC \
+ -DTEXT_BASE=$(TEXT_BASE)
+
++# Pass CONFIG_xxx settings via the command line so that we can build w/out
++# a config.h file existing in the first place. Useful for generic builds.
++CONFIG_VARS_TO_PASS = \
++ ENV_OVERWRITE \
++ OVERWRITE_ETHADDR_ONCE \
++ ETHADDR
++HOSTCPPFLAGS += \
++ $(foreach x,$(CONFIG_VARS_TO_PASS),$(if $(CONFIG_$(x)),-DCONFIG_$(x)=$(CONFIG_$(x))))
++
+ ifeq ($(MTD_VERSION),old)
+ HOSTCPPFLAGS += -DMTD_OLD
+ endif
+diff --git a/tools/env/fw_env.h b/tools/env/fw_env.h
+index a1a6807..19703c7 100644
+--- a/tools/env/fw_env.h
++++ b/tools/env/fw_env.h
+@@ -21,15 +21,6 @@
+ * MA 02111-1307 USA
+ */
+
+-/* Pull in the current config to define the default environment */
+-#ifndef __ASSEMBLY__
+-#define __ASSEMBLY__ /* get only #defines from config.h */
+-#include <config.h>
+-#undef __ASSEMBLY__
+-#else
+-#include <config.h>
+-#endif
+-
+ /*
+ * To build the utility with the static configuration
+ * comment out the next line.
+@@ -52,22 +43,6 @@
+ #define DEVICE2_ENVSECTORS 2
+ #endif
+
+-#ifndef CONFIG_BAUDRATE
+-#define CONFIG_BAUDRATE 115200
+-#endif
+-
+-#ifndef CONFIG_BOOTDELAY
+-#define CONFIG_BOOTDELAY 5 /* autoboot after 5 seconds */
+-#endif
+-
+-#ifndef CONFIG_BOOTCOMMAND
+-#define CONFIG_BOOTCOMMAND \
+- "bootp; " \
+- "setenv bootargs root=/dev/nfs nfsroot=${serverip}:${rootpath} " \
+- "ip=${ipaddr}:${serverip}:${gatewayip}:${netmask}:${hostname}::off; " \
+- "bootm"
+-#endif
+-
+ extern int fw_printenv(int argc, char *argv[]);
+ extern char *fw_getenv (char *name);
+ extern int fw_setenv (int argc, char *argv[]);
diff --git a/dev-embedded/u-boot-tools/metadata.xml b/dev-embedded/u-boot-tools/metadata.xml
new file mode 100644
index 000000000000..92114080841c
--- /dev/null
+++ b/dev-embedded/u-boot-tools/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>dev-embedded</herd>
+</pkgmetadata>
diff --git a/dev-embedded/u-boot-tools/u-boot-tools-2013.07.ebuild b/dev-embedded/u-boot-tools/u-boot-tools-2013.07.ebuild
new file mode 100644
index 000000000000..b07f862de877
--- /dev/null
+++ b/dev-embedded/u-boot-tools/u-boot-tools-2013.07.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+MY_P="u-boot-${PV/_/-}"
+DESCRIPTION="utilities for working with Das U-Boot"
+HOMEPAGE="http://www.denx.de/wiki/U-Boot/WebHome"
+SRC_URI="ftp://ftp.denx.de/pub/u-boot/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -i -e "s:-g ::" tools/Makefile || die
+ # Make sure we find local u-boot headers first #429302
+ ln -s ../include/image.h tools/ || die
+ epatch "${FILESDIR}"/u-boot-no-config.h.patch
+}
+
+src_compile() {
+ emake \
+ HOSTSTRIP=: \
+ HOSTCC="$(tc-getCC)" \
+ HOSTCFLAGS="${CFLAGS} ${CPPFLAGS}"' $(HOSTCPPFLAGS)' \
+ HOSTLDFLAGS="${LDFLAGS}" \
+ CONFIG_ENV_OVERWRITE=y \
+ tools-all
+}
+
+src_install() {
+ cd tools
+ dobin bmp_logo gen_eth_addr img2srec mkimage
+ dobin easylogo/easylogo
+ dobin env/fw_printenv
+ dosym fw_printenv /usr/bin/fw_setenv
+ insinto /etc
+ doins env/fw_env.config
+}
diff --git a/dev-embedded/u-boot-tools/u-boot-tools-2014.01.ebuild b/dev-embedded/u-boot-tools/u-boot-tools-2014.01.ebuild
new file mode 100644
index 000000000000..f7fee91fc64b
--- /dev/null
+++ b/dev-embedded/u-boot-tools/u-boot-tools-2014.01.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+MY_P="u-boot-${PV/_/-}"
+DESCRIPTION="utilities for working with Das U-Boot"
+HOMEPAGE="http://www.denx.de/wiki/U-Boot/WebHome"
+SRC_URI="ftp://ftp.denx.de/pub/u-boot/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -i "s:-g ::" tools/Makefile || die
+ # Make sure we find local u-boot headers first #429302
+ ln -s ../include/image.h tools/ || die
+ epatch "${FILESDIR}"/u-boot-no-config.h.patch
+}
+
+src_compile() {
+ emake \
+ HOSTSTRIP=: \
+ HOSTCC="$(tc-getCC)" \
+ HOSTCFLAGS="${CFLAGS} ${CPPFLAGS}"' $(HOSTCPPFLAGS)' \
+ HOSTLDFLAGS="${LDFLAGS}" \
+ CONFIG_ENV_OVERWRITE=y \
+ tools-all
+}
+
+src_install() {
+ cd tools
+ dobin bmp_logo gen_eth_addr img2srec mkimage
+ dobin easylogo/easylogo
+ dobin env/fw_printenv
+ dosym fw_printenv /usr/bin/fw_setenv
+ insinto /etc
+ doins env/fw_env.config
+}
diff --git a/dev-embedded/u-boot-tools/u-boot-tools-2015.01.ebuild b/dev-embedded/u-boot-tools/u-boot-tools-2015.01.ebuild
new file mode 100644
index 000000000000..3a0bedb4ecfe
--- /dev/null
+++ b/dev-embedded/u-boot-tools/u-boot-tools-2015.01.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+MY_P="u-boot-${PV/_/-}"
+DESCRIPTION="utilities for working with Das U-Boot"
+HOMEPAGE="http://www.denx.de/wiki/U-Boot/WebHome"
+SRC_URI="ftp://ftp.denx.de/pub/u-boot/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ # Unset a few KBUILD variables. Bug #540476
+ unset KBUILD_OUTPUT KBUILD_SRC
+ emake defconfig
+ emake \
+ HOSTSTRIP=: \
+ HOSTCC="$(tc-getCC)" \
+ HOSTCFLAGS="${CFLAGS} ${CPPFLAGS}"' $(HOSTCPPFLAGS)' \
+ HOSTLDFLAGS="${LDFLAGS}" \
+ CONFIG_ENV_OVERWRITE=y \
+ tools-all
+}
+
+src_install() {
+ cd tools
+ dobin bmp_logo gen_eth_addr img2srec mkimage
+ dobin easylogo/easylogo
+ dobin env/fw_printenv
+ dosym fw_printenv /usr/bin/fw_setenv
+ insinto /etc
+ doins env/fw_env.config
+}
diff --git a/dev-embedded/u-boot-tools/u-boot-tools-2015.04.ebuild b/dev-embedded/u-boot-tools/u-boot-tools-2015.04.ebuild
new file mode 100644
index 000000000000..c9dfa6c449b2
--- /dev/null
+++ b/dev-embedded/u-boot-tools/u-boot-tools-2015.04.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+MY_P="u-boot-${PV/_/-}"
+DESCRIPTION="utilities for working with Das U-Boot"
+HOMEPAGE="http://www.denx.de/wiki/U-Boot/WebHome"
+SRC_URI="ftp://ftp.denx.de/pub/u-boot/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ # Unset a few KBUILD variables. Bug #540476
+ unset KBUILD_OUTPUT KBUILD_SRC
+ emake defconfig
+ emake \
+ HOSTSTRIP=: \
+ STRIP=: \
+ HOSTCC="$(tc-getCC)" \
+ HOSTCFLAGS="${CFLAGS} ${CPPFLAGS}"' $(HOSTCPPFLAGS)' \
+ HOSTLDFLAGS="${LDFLAGS}" \
+ CONFIG_ENV_OVERWRITE=y \
+ tools-all
+}
+
+src_install() {
+ cd tools
+ dobin bmp_logo gen_eth_addr img2srec mkimage
+ dobin easylogo/easylogo
+ dobin env/fw_printenv
+ dosym fw_printenv /usr/bin/fw_setenv
+ insinto /etc
+ doins env/fw_env.config
+ doman "${S}/doc/mkimage.1"
+}