summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/u-boot-tools/Manifest1
-rw-r--r--dev-embedded/u-boot-tools/u-boot-tools-2016.03.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-embedded/u-boot-tools/Manifest b/dev-embedded/u-boot-tools/Manifest
index 012e9ebc10d4..202c61af62ba 100644
--- a/dev-embedded/u-boot-tools/Manifest
+++ b/dev-embedded/u-boot-tools/Manifest
@@ -2,3 +2,4 @@ DIST u-boot-2013.07.tar.bz2 10067674 SHA256 2bbd440c1b29928d230604eac372fda5152d
DIST u-boot-2014.01.tar.bz2 10180625 SHA256 cdaf8c81583abfa2e73da46cfcf87b0cbd9741d9aa766f3b905376e3652d543d SHA512 c6e4f6f9a2dae1a50b7dd94dad13ef5d0ce440c3f0401de3f0ecf907c8fca0ff183077ec3b2c4da42b0fa9775450b03571725c76dfd2419a4ee7b982c261ccb1 WHIRLPOOL 9964abde477ce54dfe0a0972920e19c6d60209e8a19819c98b955a9a8b23cc57ac8e687d9ced65411eb6ff1ac40121edac154e754b3b5a2f037cf3a7724de374
DIST u-boot-2015.01.tar.bz2 9982195 SHA256 383051a656ebe11757b17d38a3326387e4a1b0949ca8a9e8ee506bf71dac9fde SHA512 6697c6da5f463bdfa75b8025a2dd302e9cda58ce36bc3252590f11976807aeccc1ca76be93cbc83d3367a7557878516bb57130ffb76197ffd513640c48e18938 WHIRLPOOL 7ed552f0f32d061c1723c42f0230611d6552068765ea3130fe070d1a906da2defafa14a67078ef7feda4ed29857f51a5b47b3595aa7a8eb07bf26778a3517aff
DIST u-boot-2015.04.tar.bz2 9471487 SHA256 0a1a70df586655f527befa6f12e184e96ed61b126e5a567382321b17200f5d60 SHA512 e50a3d7e44bf588a7cf8e28cdf3342bc38bd1bf55231d579c2501b75386cfff0fbc7a34648d893971e0095510c9d582b7180427832cb78470b4e7af2ce0e3646 WHIRLPOOL dbfd4b13b82505ef94e8b394ba260684ee18c881bd84adfc841194ce6a4b967c8514cedfcac6777045a50b940e3a1882af667e152dc0fc0d3b9254a7dfca89d0
+DIST u-boot-2016.03.tar.bz2 11076762 SHA256 e49337262ecac44dbdeac140f2c6ebd1eba345e0162b0464172e7f05583ed7bb SHA512 d3a8d5f334a1a1a33756d9ac33d14eca689cafe1ada478e61b51dcbff1781266d4f0ea121e25d0232b292475721c04be63e5a153715b91a14dfc82656a54de6f WHIRLPOOL 32f246e3bdb71648f47a4246602b6f27de5dbae9834aed71880c5d5e737dfd63adcd03e9b47874b4fa61c0336fe13b8b079693baec633bd428d991abb47a88f0
diff --git a/dev-embedded/u-boot-tools/u-boot-tools-2016.03.ebuild b/dev-embedded/u-boot-tools/u-boot-tools-2016.03.ebuild
new file mode 100644
index 000000000000..1bce507ba284
--- /dev/null
+++ b/dev-embedded/u-boot-tools/u-boot-tools-2016.03.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils toolchain-funcs
+
+MY_P="u-boot-${PV/_/-}"
+DESCRIPTION="utilities for working with Das U-Boot"
+HOMEPAGE="http://www.denx.de/wiki/U-Boot/WebHome"
+SRC_URI="ftp://ftp.denx.de/pub/u-boot/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ # Unset a few KBUILD variables. Bug #540476
+ unset KBUILD_OUTPUT KBUILD_SRC
+ emake defconfig
+ emake \
+ HOSTSTRIP=: \
+ STRIP=: \
+ HOSTCC="$(tc-getCC)" \
+ HOSTCFLAGS="${CFLAGS} ${CPPFLAGS}"' $(HOSTCPPFLAGS)' \
+ HOSTLDFLAGS="${LDFLAGS}" \
+ CONFIG_ENV_OVERWRITE=y \
+ tools-all
+}
+
+src_install() {
+ cd tools
+ dobin bmp_logo gen_eth_addr img2srec mkimage
+ dobin easylogo/easylogo
+ dobin env/fw_printenv
+ dosym fw_printenv /usr/bin/fw_setenv
+ insinto /etc
+ doins env/fw_env.config
+ doman "${S}/doc/mkimage.1"
+}