summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/t4k-common/Manifest2
-rw-r--r--dev-games/t4k-common/metadata.xml3
-rw-r--r--dev-games/t4k-common/t4k-common-0.1.1.ebuild8
3 files changed, 8 insertions, 5 deletions
diff --git a/dev-games/t4k-common/Manifest b/dev-games/t4k-common/Manifest
index 486bc2ce1cc5..6d4292f4cbb9 100644
--- a/dev-games/t4k-common/Manifest
+++ b/dev-games/t4k-common/Manifest
@@ -1 +1 @@
-DIST t4k_common-0.1.1.tar.gz 629215 BLAKE2B e85619ae0526aa51dc2075e5b845eaf778772cc7b354cb2a8d6737602695dbeea798de980ddefce1ec951b3700059a936bef291f140acf6424001e6647fe8643 SHA512 ddf9c0ccf1b6a4ab9f009794262fef86587e31e5110e5a8041214d7c94c607b9f4ca5ec21f04254bfc00a625ab75a04a69b3dcaff9ec13dbb92d5d82b6e375cf
+DIST t4k-common-0.1.1.tar.gz 622239 BLAKE2B f2ddbb3b8815ad05001f99b8cfd49fda3c1f59e9dc340bf9739c2072e9f4a2faf069bf9f774f95818a0cb59302e557d3d6408530e8ff82adb6b9fd84b36e2641 SHA512 d7fdb469452637187adcb4b5d2907c05687765b1b75cd3a28b75222b2a0358f1962e1a245d88129b4dbede845fde8ff718cf9a7b0f97a12cb21a8791073fbe3d
diff --git a/dev-games/t4k-common/metadata.xml b/dev-games/t4k-common/metadata.xml
index 26079e608bed..9abddaa683a4 100644
--- a/dev-games/t4k-common/metadata.xml
+++ b/dev-games/t4k-common/metadata.xml
@@ -5,4 +5,7 @@
<email>games@gentoo.org</email>
<name>Gentoo Games Project</name>
</maintainer>
+ <upstream>
+ <remote-id type="github">tux4kids/t4kcommon</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-games/t4k-common/t4k-common-0.1.1.ebuild b/dev-games/t4k-common/t4k-common-0.1.1.ebuild
index ed40644465c3..2b12a55927ca 100644
--- a/dev-games/t4k-common/t4k-common-0.1.1.ebuild
+++ b/dev-games/t4k-common/t4k-common-0.1.1.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
inherit eutils
DESCRIPTION="A library of code shared between tuxmath and tuxtype"
-HOMEPAGE="http://tux4kids.alioth.debian.org/tuxmath/download.php"
-SRC_URI="http://alioth.debian.org/frs/download.php/3540/t4k_common-${PV}.tar.gz"
+HOMEPAGE="https://github.com/tux4kids/t4kcommon"
+SRC_URI="https://github.com/tux4kids/t4kcommon/archive/upstream/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
@@ -28,7 +28,7 @@ RDEPEND="dev-libs/libxml2:2
DEPEND="${RDEPEND}
virtual/pkgconfig"
-S=${WORKDIR}/t4k_common-${PV}
+S=${WORKDIR}/t4kcommon-upstream-${PV}
src_prepare() {
epatch "${FILESDIR}"/${P}-libpng.patch