summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-go/go-tools/go-tools-0_pre20150902.ebuild')
-rw-r--r--dev-go/go-tools/go-tools-0_pre20150902.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/dev-go/go-tools/go-tools-0_pre20150902.ebuild b/dev-go/go-tools/go-tools-0_pre20150902.ebuild
index aa176ff4d38d..7d598bdab2bf 100644
--- a/dev-go/go-tools/go-tools-0_pre20150902.ebuild
+++ b/dev-go/go-tools/go-tools-0_pre20150902.ebuild
@@ -56,8 +56,6 @@ src_prepare() {
-i src/${go_src}/go/types/stdlib_test.go || die
sed -e 's:TestRepoRootForImportPath(:_\0:' \
-i src/${go_src}/go/vcs/vcs_test.go || die
- sed -e 's:TestStdlib(:_\0:' \
- -i src/${go_src}/refactor/lexical/lexical_test.go || die
# Add favicon to the godoc web interface (bug 551030)
cp "${DISTDIR}"/go-favicon.ico "src/${go_src}/godoc/static/favicon.ico" ||
@@ -77,6 +75,14 @@ src_compile() {
golang-build_src_compile
}
+src_test() {
+ # Create a writable GOROOT in order to avoid sandbox violations.
+ cp -sR "$(go env GOROOT)" "${T}/goroot" || die
+ mkdir -p "${T}/goroot/test" || die
+ GOROOT="${T}/goroot" golang-build_src_test
+ rm -rf "${T}/goroot"
+}
+
src_install() {
# Create a writable GOROOT in order to avoid sandbox violations.
cp -sR "$(go env GOROOT)" "${T}/goroot" || die