summaryrefslogtreecommitdiff
path: root/dev-go
diff options
context:
space:
mode:
Diffstat (limited to 'dev-go')
-rw-r--r--dev-go/go-tour/go-tour-0_p20180810.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/dev-go/go-tour/go-tour-0_p20180810.ebuild b/dev-go/go-tour/go-tour-0_p20180810.ebuild
index 0266d4dd62b2..42d9aa99327c 100644
--- a/dev-go/go-tour/go-tour-0_p20180810.ebuild
+++ b/dev-go/go-tour/go-tour-0_p20180810.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -24,6 +24,7 @@ src_compile() {
for x in net tools; do
ln -s "$(get_golibdir_gopath)/src/golang.org/x/${x}" "${T}/golibdir/src/golang.org/x/${x}" || die
done
+ export -n GOCACHE XDG_CACHE_HOME #567192
GOPATH="${S}:${T}/golibdir" GOBIN="${S}/bin" \
go install -v -work -x ${EGO_BUILD_FLAGS} "${EGO_PN}"
[[ -x bin/gotour ]] || die "gotour not found"