summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/bytestring-handle/bytestring-handle-0.1.0.6.ebuild')
-rw-r--r--dev-haskell/bytestring-handle/bytestring-handle-0.1.0.6.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-haskell/bytestring-handle/bytestring-handle-0.1.0.6.ebuild b/dev-haskell/bytestring-handle/bytestring-handle-0.1.0.6.ebuild
new file mode 100644
index 000000000000..fa9840c071ac
--- /dev/null
+++ b/dev-haskell/bytestring-handle/bytestring-handle-0.1.0.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="ByteString-backed Handles"
+HOMEPAGE="http://hub.darcs.net/ganesh/bytestring-handle"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hunit-1.2 <dev-haskell/hunit-1.7
+ >=dev-haskell/quickcheck-2.1.2
+ >=dev-haskell/test-framework-0.2.0 <dev-haskell/test-framework-0.9
+ >=dev-haskell/test-framework-hunit-0.2.0 <dev-haskell/test-framework-hunit-0.4
+ >=dev-haskell/test-framework-quickcheck2-0.2.5 <dev-haskell/test-framework-quickcheck2-0.4 )
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'base >= 4.2 && < 4.11' 'base >= 4.2' \
+ 'QuickCheck >= 2.1.2 && < 2.11' 'QuickCheck >= 2.1.2'
+}