summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/test-framework-quickcheck2/test-framework-quickcheck2-0.3.0.5-r1.ebuild')
-rw-r--r--dev-haskell/test-framework-quickcheck2/test-framework-quickcheck2-0.3.0.5-r1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-haskell/test-framework-quickcheck2/test-framework-quickcheck2-0.3.0.5-r1.ebuild b/dev-haskell/test-framework-quickcheck2/test-framework-quickcheck2-0.3.0.5-r1.ebuild
new file mode 100644
index 000000000000..1e46f5e0459e
--- /dev/null
+++ b/dev-haskell/test-framework-quickcheck2/test-framework-quickcheck2-0.3.0.5-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.5.6.9999
+#hackport: flags: +base4
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="QuickCheck2 support for the test-framework package"
+HOMEPAGE="http://haskell.github.io/test-framework/"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/extensible-exceptions-0.1.1:=[profile?] <dev-haskell/extensible-exceptions-0.2.0:=[profile?]
+ >=dev-haskell/quickcheck-2.4:2=[profile?]
+ >=dev-haskell/random-1:=[profile?] <dev-haskell/random-1.2:=[profile?]
+ >=dev-haskell/test-framework-0.8:=[profile?] <dev-haskell/test-framework-0.9:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+"
+
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'QuickCheck >= 2.4 && < 2.13' 'QuickCheck >= 2.4'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=base4
+}