summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/istack-commons-runtime/istack-commons-runtime-20070122-r1.ebuild')
-rw-r--r--dev-java/istack-commons-runtime/istack-commons-runtime-20070122-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-java/istack-commons-runtime/istack-commons-runtime-20070122-r1.ebuild b/dev-java/istack-commons-runtime/istack-commons-runtime-20070122-r1.ebuild
new file mode 100644
index 000000000000..e0d761ea46d1
--- /dev/null
+++ b/dev-java/istack-commons-runtime/istack-commons-runtime-20070122-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="istack-commons"
+HOMEPAGE="https://istack-commons.dev.java.net/"
+SRC_URI="mirror://gentoo/istack-commons-${PV}.tar.bz2"
+
+LICENSE="CDDL"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+IUSE=""
+
+COMMON_DEP="java-virtuals/jaf"
+
+DEPEND=">=virtual/jdk-1.5
+ ${COMMON_DEP}"
+RDEPEND=">=virtual/jre-1.5
+ ${COMMON_DEP}"
+
+S="${WORKDIR}/istack-commons-${PV}"
+
+src_unpack() {
+ unpack ${A}
+
+ java-ant_bsfix_one "${S}/build-common.xml"
+
+ java-pkg_jarfrom --into "${S}/runtime/lib" --virtual jaf
+}
+
+EANT_BUILD_XML="runtime/build.xml"
+
+src_install() {
+
+ java-pkg_dojar runtime/build/istack-commons-runtime.jar
+
+ use source && java-pkg_dosrc runtime/src/*
+}