summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/rakudo')
-rw-r--r--dev-lang/rakudo/Manifest6
-rw-r--r--dev-lang/rakudo/rakudo-2017.07.ebuild72
-rw-r--r--dev-lang/rakudo/rakudo-2017.08.ebuild72
-rw-r--r--dev-lang/rakudo/rakudo-2017.09.ebuild72
-rw-r--r--dev-lang/rakudo/rakudo-2017.10.ebuild72
-rw-r--r--dev-lang/rakudo/rakudo-2017.11.ebuild72
-rw-r--r--dev-lang/rakudo/rakudo-2017.12.ebuild72
7 files changed, 0 insertions, 438 deletions
diff --git a/dev-lang/rakudo/Manifest b/dev-lang/rakudo/Manifest
index a264233c874..049868463d6 100644
--- a/dev-lang/rakudo/Manifest
+++ b/dev-lang/rakudo/Manifest
@@ -1,9 +1,3 @@
-DIST rakudo-2017.07.tar.gz 2984621 BLAKE2B 5ded4a8577e8bc49003115955103897a79b5d4df914995ad724949bd372514d7095dc68eaaff875747335945c9d6208b9ab7ab12d34190fe0c3d38682b7b3f22 SHA512 a80fba71bce8a6537962c5728ef1b54c6bfd275b9a4b7caacc6497f12a826b293a3a2bf8c412b21e91bb29bd3a325d9da17ecd8abb0ba2ffd4b8eecf0297d39f
-DIST rakudo-2017.08.tar.gz 2992885 BLAKE2B d0edc01d0950fbcb8d1e3dd61bd4838e6d07a1940611ecc2111ffefc3914d3b90af3b5b62c79d02651ea1877986b3ce405482aed0753958e90b8c9d6b75e4f2d SHA512 61091f1181bc1d95433650ecc8ee318cf7ef4ee1a67d492020654e8abd5095368d8a0e3d20647f336de5864eba5f8ef4cf1ce54d09763cf79cc1b7c5c457a300
-DIST rakudo-2017.09.tar.gz 3006759 BLAKE2B 22df3775aed16bf404a2f1bf716c22989c7cd0e22c3000cfccbcde6525ba5a7dd94814be35d6106590d3ccb54c8b2748aeb202c3e372fafba84e4c7dcbc8db6d SHA512 6ae257430436586a519cc411771c5a19c3bf6aefcb5b02cd1751184ccd8f2fe860ce33c53421ff1fd48a598f27532932a1754407fb0f6a1861da0808c5876b9b
-DIST rakudo-2017.10.tar.gz 3049348 BLAKE2B 7e017635a6807d25b0c62c312db5c86199cca1f7d405b7a55b09cfdff922e67b63df66cafd547bc555c4adaf146a8cb2eeb8de5110e844042721f24e4efe9e95 SHA512 f3832a5dcd0048a7d9018c46e8430245b3d6565516d61f4dc57ff06d5dbf38afab7b9a4791a0f88ef4422899418f3ce550e5271cef668ab74804f898c8c5faaa
-DIST rakudo-2017.11.tar.gz 3063336 BLAKE2B 781c2359c93e25e1a0429ea509923b0ca76a6a7a2e7d467ff9fc08eb4cfd915ef37641242db9cf92c725b74938b4555f111f4ccdd2af75b46450767f58517994 SHA512 6cb36938e1d395e5271939fed69fb0e2ebfccbf738a7d2cfef620853dfbc157efad4aa802f3c3fcf5d232c291ae0ab21f5bb65c7a17d8a5857c143e7e8976fc3
-DIST rakudo-2017.12.tar.gz 3076450 BLAKE2B b97fa774a307486d7af830478d031cef64f3d4ae95192c8d99f1247e349ebccc83dfd3e864d3c829722b9388d6c9ca667ef55f42c8df86cba10278ff9affbc23 SHA512 0c7870ea90bc219cc27c4ea6130ef6e46172d0cd8da3d0b49dc8c8585cddc87a004dfa945075254a6bca3005d7bc68f181c79e229084f97e532ad086c512bf44
DIST rakudo-2018.01.tar.gz 3089785 BLAKE2B 6e74c17b44e489a5a1a60f177290962eac752ad5750dd5d6e64e5a9264d8b6ba7dfe4234087a1b1cbebd3933376b83dd305c3bd255ad39bc81b9c99b8e51b303 SHA512 5030089265f7c4d0bde663eb1d26a0e40ddc9b1dedfd7a350a2238f5136f08abb986d2568c05efe031248ecacdd19888be6e08b954bbeedc03e769d3016b17ea
DIST rakudo-2018.02.1.tar.gz 3478957 BLAKE2B 39568af458cc15705db48f607675a7ca4fe2d6430fdaac42e37b7096f0974d42788fa0965ee9da61c2ae56dafb27e3d759007c6600f291a07c0dc50dd1d34638 SHA512 59be2c41e6b1784fb9eaf7590ee77d8424c449d7c58e93c66f3adde5be3fe05260c41c01171c8fb59542b32bb5ee5064e1c9be69efc3e8cb20554b09b10240ea
DIST rakudo-2018.02.tar.gz 3478799 BLAKE2B 36f50a38c26e9b96a31d63566337315bed41bdd9b19e3b4e74dcdd1e0b56a060b0fcd7430078250e7e3b45473f7ee08ee0f059f10e1d01a24f0a3f08fe43c158 SHA512 743dbe01c20388e7c0f1af6f8175def283f9c92ac6f2c3b7d8c442c03d5204de8bd12d33f6ee99d75f9c0a171ca96cc2a3438b2ebfa0265d80441b353c64bbc4
diff --git a/dev-lang/rakudo/rakudo-2017.07.ebuild b/dev-lang/rakudo/rakudo-2017.07.ebuild
deleted file mode 100644
index 0916271bb83..00000000000
--- a/dev-lang/rakudo/rakudo-2017.07.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit java-pkg-opt-2
-
-DESCRIPTION="A compiler for the Perl 6 programming language"
-HOMEPAGE="http://rakudo.org"
-
-if [[ ${PV} == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/rakudo/${PN}.git"
- inherit git-r3
- KEYWORDS=""
-else
- SRC_URI="https://rakudo.perl6.org/downloads/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="Artistic-2"
-SLOT="0"
-# TODO: add USE="javascript" once that's usable in nqp
-IUSE="clang java +moar test"
-REQUIRED_USE="|| ( java moar )"
-
-CDEPEND="~dev-lang/nqp-${PV}:${SLOT}=[java?,moar?,clang=]"
-RDEPEND="${CDEPEND}
- java? ( >=virtual/jre-1.7 )"
-DEPEND="${CDEPEND}
- clang? ( sys-devel/clang )
- java? ( >=virtual/jdk-1.7 )
- >=dev-lang/perl-5.10"
-
-pkg_pretend() {
- if has_version dev-lang/rakudo; then
- ewarn "Rakudo is known to fail compilation/installation with Rakudo"
- ewarn "already being installed. So if it fails, try unmerging dev-lang/rakudo,"
- ewarn "then do a new installation."
- ewarn "(see Bug #584394)"
- fi
-}
-
-src_configure() {
- local backends
- use moar && backends+="moar,"
- use java && backends+="jvm"
-
- local myargs=(
- "--prefix=/usr"
- "--sysroot=/"
- "--sdkroot=/"
- "--backends=${backends}"
- )
-
- perl Configure.pl "${myargs[@]}" || die
-
- if use java; then
- NQP=$(java-pkg_getjars --with-dependencies nqp)
- fi
-}
-
-src_compile() {
- emake DESTDIR="${D}" NQP_JARS="${NQP}" BLD_NQP_JARS="${NQP}"
-}
-
-src_install() {
- emake DESTDIR="${D}" NQP_JARS="${NQP}" BLD_NQP_JARS="${NQP}" install
-}
-
-src_test() {
- RAKUDO_PRECOMP_PREFIX=$(mktemp -d) default
-}
diff --git a/dev-lang/rakudo/rakudo-2017.08.ebuild b/dev-lang/rakudo/rakudo-2017.08.ebuild
deleted file mode 100644
index 0916271bb83..00000000000
--- a/dev-lang/rakudo/rakudo-2017.08.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit java-pkg-opt-2
-
-DESCRIPTION="A compiler for the Perl 6 programming language"
-HOMEPAGE="http://rakudo.org"
-
-if [[ ${PV} == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/rakudo/${PN}.git"
- inherit git-r3
- KEYWORDS=""
-else
- SRC_URI="https://rakudo.perl6.org/downloads/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="Artistic-2"
-SLOT="0"
-# TODO: add USE="javascript" once that's usable in nqp
-IUSE="clang java +moar test"
-REQUIRED_USE="|| ( java moar )"
-
-CDEPEND="~dev-lang/nqp-${PV}:${SLOT}=[java?,moar?,clang=]"
-RDEPEND="${CDEPEND}
- java? ( >=virtual/jre-1.7 )"
-DEPEND="${CDEPEND}
- clang? ( sys-devel/clang )
- java? ( >=virtual/jdk-1.7 )
- >=dev-lang/perl-5.10"
-
-pkg_pretend() {
- if has_version dev-lang/rakudo; then
- ewarn "Rakudo is known to fail compilation/installation with Rakudo"
- ewarn "already being installed. So if it fails, try unmerging dev-lang/rakudo,"
- ewarn "then do a new installation."
- ewarn "(see Bug #584394)"
- fi
-}
-
-src_configure() {
- local backends
- use moar && backends+="moar,"
- use java && backends+="jvm"
-
- local myargs=(
- "--prefix=/usr"
- "--sysroot=/"
- "--sdkroot=/"
- "--backends=${backends}"
- )
-
- perl Configure.pl "${myargs[@]}" || die
-
- if use java; then
- NQP=$(java-pkg_getjars --with-dependencies nqp)
- fi
-}
-
-src_compile() {
- emake DESTDIR="${D}" NQP_JARS="${NQP}" BLD_NQP_JARS="${NQP}"
-}
-
-src_install() {
- emake DESTDIR="${D}" NQP_JARS="${NQP}" BLD_NQP_JARS="${NQP}" install
-}
-
-src_test() {
- RAKUDO_PRECOMP_PREFIX=$(mktemp -d) default
-}
diff --git a/dev-lang/rakudo/rakudo-2017.09.ebuild b/dev-lang/rakudo/rakudo-2017.09.ebuild
deleted file mode 100644
index 0916271bb83..00000000000
--- a/dev-lang/rakudo/rakudo-2017.09.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit java-pkg-opt-2
-
-DESCRIPTION="A compiler for the Perl 6 programming language"
-HOMEPAGE="http://rakudo.org"
-
-if [[ ${PV} == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/rakudo/${PN}.git"
- inherit git-r3
- KEYWORDS=""
-else
- SRC_URI="https://rakudo.perl6.org/downloads/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="Artistic-2"
-SLOT="0"
-# TODO: add USE="javascript" once that's usable in nqp
-IUSE="clang java +moar test"
-REQUIRED_USE="|| ( java moar )"
-
-CDEPEND="~dev-lang/nqp-${PV}:${SLOT}=[java?,moar?,clang=]"
-RDEPEND="${CDEPEND}
- java? ( >=virtual/jre-1.7 )"
-DEPEND="${CDEPEND}
- clang? ( sys-devel/clang )
- java? ( >=virtual/jdk-1.7 )
- >=dev-lang/perl-5.10"
-
-pkg_pretend() {
- if has_version dev-lang/rakudo; then
- ewarn "Rakudo is known to fail compilation/installation with Rakudo"
- ewarn "already being installed. So if it fails, try unmerging dev-lang/rakudo,"
- ewarn "then do a new installation."
- ewarn "(see Bug #584394)"
- fi
-}
-
-src_configure() {
- local backends
- use moar && backends+="moar,"
- use java && backends+="jvm"
-
- local myargs=(
- "--prefix=/usr"
- "--sysroot=/"
- "--sdkroot=/"
- "--backends=${backends}"
- )
-
- perl Configure.pl "${myargs[@]}" || die
-
- if use java; then
- NQP=$(java-pkg_getjars --with-dependencies nqp)
- fi
-}
-
-src_compile() {
- emake DESTDIR="${D}" NQP_JARS="${NQP}" BLD_NQP_JARS="${NQP}"
-}
-
-src_install() {
- emake DESTDIR="${D}" NQP_JARS="${NQP}" BLD_NQP_JARS="${NQP}" install
-}
-
-src_test() {
- RAKUDO_PRECOMP_PREFIX=$(mktemp -d) default
-}
diff --git a/dev-lang/rakudo/rakudo-2017.10.ebuild b/dev-lang/rakudo/rakudo-2017.10.ebuild
deleted file mode 100644
index 0916271bb83..00000000000
--- a/dev-lang/rakudo/rakudo-2017.10.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit java-pkg-opt-2
-
-DESCRIPTION="A compiler for the Perl 6 programming language"
-HOMEPAGE="http://rakudo.org"
-
-if [[ ${PV} == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/rakudo/${PN}.git"
- inherit git-r3
- KEYWORDS=""
-else
- SRC_URI="https://rakudo.perl6.org/downloads/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="Artistic-2"
-SLOT="0"
-# TODO: add USE="javascript" once that's usable in nqp
-IUSE="clang java +moar test"
-REQUIRED_USE="|| ( java moar )"
-
-CDEPEND="~dev-lang/nqp-${PV}:${SLOT}=[java?,moar?,clang=]"
-RDEPEND="${CDEPEND}
- java? ( >=virtual/jre-1.7 )"
-DEPEND="${CDEPEND}
- clang? ( sys-devel/clang )
- java? ( >=virtual/jdk-1.7 )
- >=dev-lang/perl-5.10"
-
-pkg_pretend() {
- if has_version dev-lang/rakudo; then
- ewarn "Rakudo is known to fail compilation/installation with Rakudo"
- ewarn "already being installed. So if it fails, try unmerging dev-lang/rakudo,"
- ewarn "then do a new installation."
- ewarn "(see Bug #584394)"
- fi
-}
-
-src_configure() {
- local backends
- use moar && backends+="moar,"
- use java && backends+="jvm"
-
- local myargs=(
- "--prefix=/usr"
- "--sysroot=/"
- "--sdkroot=/"
- "--backends=${backends}"
- )
-
- perl Configure.pl "${myargs[@]}" || die
-
- if use java; then
- NQP=$(java-pkg_getjars --with-dependencies nqp)
- fi
-}
-
-src_compile() {
- emake DESTDIR="${D}" NQP_JARS="${NQP}" BLD_NQP_JARS="${NQP}"
-}
-
-src_install() {
- emake DESTDIR="${D}" NQP_JARS="${NQP}" BLD_NQP_JARS="${NQP}" install
-}
-
-src_test() {
- RAKUDO_PRECOMP_PREFIX=$(mktemp -d) default
-}
diff --git a/dev-lang/rakudo/rakudo-2017.11.ebuild b/dev-lang/rakudo/rakudo-2017.11.ebuild
deleted file mode 100644
index 0916271bb83..00000000000
--- a/dev-lang/rakudo/rakudo-2017.11.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit java-pkg-opt-2
-
-DESCRIPTION="A compiler for the Perl 6 programming language"
-HOMEPAGE="http://rakudo.org"
-
-if [[ ${PV} == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/rakudo/${PN}.git"
- inherit git-r3
- KEYWORDS=""
-else
- SRC_URI="https://rakudo.perl6.org/downloads/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="Artistic-2"
-SLOT="0"
-# TODO: add USE="javascript" once that's usable in nqp
-IUSE="clang java +moar test"
-REQUIRED_USE="|| ( java moar )"
-
-CDEPEND="~dev-lang/nqp-${PV}:${SLOT}=[java?,moar?,clang=]"
-RDEPEND="${CDEPEND}
- java? ( >=virtual/jre-1.7 )"
-DEPEND="${CDEPEND}
- clang? ( sys-devel/clang )
- java? ( >=virtual/jdk-1.7 )
- >=dev-lang/perl-5.10"
-
-pkg_pretend() {
- if has_version dev-lang/rakudo; then
- ewarn "Rakudo is known to fail compilation/installation with Rakudo"
- ewarn "already being installed. So if it fails, try unmerging dev-lang/rakudo,"
- ewarn "then do a new installation."
- ewarn "(see Bug #584394)"
- fi
-}
-
-src_configure() {
- local backends
- use moar && backends+="moar,"
- use java && backends+="jvm"
-
- local myargs=(
- "--prefix=/usr"
- "--sysroot=/"
- "--sdkroot=/"
- "--backends=${backends}"
- )
-
- perl Configure.pl "${myargs[@]}" || die
-
- if use java; then
- NQP=$(java-pkg_getjars --with-dependencies nqp)
- fi
-}
-
-src_compile() {
- emake DESTDIR="${D}" NQP_JARS="${NQP}" BLD_NQP_JARS="${NQP}"
-}
-
-src_install() {
- emake DESTDIR="${D}" NQP_JARS="${NQP}" BLD_NQP_JARS="${NQP}" install
-}
-
-src_test() {
- RAKUDO_PRECOMP_PREFIX=$(mktemp -d) default
-}
diff --git a/dev-lang/rakudo/rakudo-2017.12.ebuild b/dev-lang/rakudo/rakudo-2017.12.ebuild
deleted file mode 100644
index b442d400879..00000000000
--- a/dev-lang/rakudo/rakudo-2017.12.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit java-pkg-opt-2
-
-DESCRIPTION="A compiler for the Perl 6 programming language"
-HOMEPAGE="http://rakudo.org"
-
-if [[ ${PV} == "9999" ]]; then
- EGIT_REPO_URI="https://github.com/rakudo/${PN}.git"
- inherit git-r3
- KEYWORDS=""
-else
- SRC_URI="https://rakudo.perl6.org/downloads/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="Artistic-2"
-SLOT="0"
-# TODO: add USE="javascript" once that's usable in nqp
-IUSE="clang java +moar test"
-REQUIRED_USE="|| ( java moar )"
-
-CDEPEND="~dev-lang/nqp-${PV}:${SLOT}=[java?,moar?,clang=]"
-RDEPEND="${CDEPEND}
- java? ( >=virtual/jre-1.7 )"
-DEPEND="${CDEPEND}
- clang? ( sys-devel/clang )
- java? ( >=virtual/jdk-1.7 )
- >=dev-lang/perl-5.10"
-
-pkg_pretend() {
- if has_version dev-lang/rakudo; then
- ewarn "Rakudo is known to fail compilation/installation with Rakudo"
- ewarn "already being installed. So if it fails, try unmerging dev-lang/rakudo,"
- ewarn "then do a new installation."
- ewarn "(see Bug #584394)"
- fi
-}
-
-src_configure() {
- local backends
- use moar && backends+="moar,"
- use java && backends+="jvm"
-
- local myargs=(
- "--prefix=/usr"
- "--sysroot=/"
- "--sdkroot=/"
- "--backends=${backends}"
- )
-
- perl Configure.pl "${myargs[@]}" || die
-
- if use java; then
- NQP=$(java-pkg_getjars --with-dependencies nqp)
- fi
-}
-
-src_compile() {
- emake DESTDIR="${D}" NQP_JARS="${NQP}" BLD_NQP_JARS="${NQP}"
-}
-
-src_install() {
- emake DESTDIR="${D}" NQP_JARS="${NQP}" BLD_NQP_JARS="${NQP}" install
-}
-
-src_test() {
- RAKUDO_PRECOMP_PREFIX=$(mktemp -d) default
-}