summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/yasm')
-rw-r--r--dev-lang/yasm/yasm-1.3.0.ebuild4
-rw-r--r--dev-lang/yasm/yasm-9999.ebuild4
2 files changed, 6 insertions, 2 deletions
diff --git a/dev-lang/yasm/yasm-1.3.0.ebuild b/dev-lang/yasm/yasm-1.3.0.ebuild
index fab7341fef10..7104a751fd07 100644
--- a/dev-lang/yasm/yasm-1.3.0.ebuild
+++ b/dev-lang/yasm/yasm-1.3.0.ebuild
@@ -5,7 +5,7 @@ EAPI=5
PYTHON_COMPAT=( python2_7 )
-inherit python-single-r1
+inherit python-single-r1 toolchain-funcs
DESCRIPTION="An assembler for x86 and x86_64 instruction sets"
HOMEPAGE="http://yasm.tortall.net/"
@@ -34,6 +34,8 @@ src_configure() {
XMLTO=: \
econf \
+ CC_FOR_BUILD=$(tc-getBUILD_CC) \
+ CCLD_FOR_BUILD=$(tc-getBUILD_CC) \
$(use_enable python) \
$(use_enable python python-bindings) \
$(use_enable nls)
diff --git a/dev-lang/yasm/yasm-9999.ebuild b/dev-lang/yasm/yasm-9999.ebuild
index cf48d28e8623..ccd86bc00909 100644
--- a/dev-lang/yasm/yasm-9999.ebuild
+++ b/dev-lang/yasm/yasm-9999.ebuild
@@ -4,7 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python2_7 )
-inherit python-single-r1
+inherit python-single-r1 toolchain-funcs
if [[ ${PV} == 9999* ]] ; then
EGIT_REPO_URI="https://github.com/yasm/yasm.git"
@@ -60,6 +60,8 @@ src_configure() {
use python && python_setup
local myconf=(
+ CC_FOR_BUILD=$(tc-getBUILD_CC) \
+ CCLD_FOR_BUILD=$(tc-getBUILD_CC) \
--disable-warnerror
$(use_enable python)
$(use_enable python python-bindings)