summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/mujs/Manifest1
-rw-r--r--dev-lang/mujs/files/mujs-1.0.4-gentoo.patch23
-rw-r--r--dev-lang/mujs/mujs-1.0.4.ebuild42
3 files changed, 0 insertions, 66 deletions
diff --git a/dev-lang/mujs/Manifest b/dev-lang/mujs/Manifest
index 5f729fce1ca6..0200ee406a77 100644
--- a/dev-lang/mujs/Manifest
+++ b/dev-lang/mujs/Manifest
@@ -1,2 +1 @@
-DIST mujs-1.0.4.tar.xz 91520 BLAKE2B 6ffe62b19b140e2ae63ebe59a3b3bd352936ccba53dda3b0fcf575440dc790a0767c7de8c0a1441d26c11c65074520a80050cc0efa1113be0df51a802e719574 SHA512 a32498fee20ab6ddc8bbf79b4fdd82f3560d4e4b28bbe57c4e8f1df4a8a5367a689b6c9a391761abe47a8f15d2832fede4a508330eb181744b9563ae9954c102
DIST mujs-1.0.5.tar.gz 119353 BLAKE2B 48f1b598e50d5804b0d64230cdd6b4d3f719187ea0906f45c9f45baee2c8df59c6fd09dc25afc9e1ce4e20a9866d158d16a4632bec552fddd8fac70b20e2363f SHA512 c1c59b5e80e0e5f580f30dfc0b4707b6a1e44a73c746b9783bb24d91429ddf8ed670a7663478300cc568cfc15a511720b6d18be2ade40a3a66fc7ab8f3933c2d
diff --git a/dev-lang/mujs/files/mujs-1.0.4-gentoo.patch b/dev-lang/mujs/files/mujs-1.0.4-gentoo.patch
deleted file mode 100644
index c05b8787466c..000000000000
--- a/dev-lang/mujs/files/mujs-1.0.4-gentoo.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-1. Add to user-defined CFLAGS instead of being overwritten by them
-2. Don't strip binaries: it leads to QA warnings
-diff --git a/Makefile b/Makefile
-index 7284f51..7615158 100644
---- a/Makefile
-+++ b/Makefile
-@@ -15,7 +15,7 @@ endif
-
- # Compiler flags for various configurations:
-
--CFLAGS := -std=c99 -pedantic -Wall -Wextra -Wno-unused-parameter
-+CFLAGS += -std=c99 -pedantic -Wall -Wextra -Wno-unused-parameter
-
- ifeq "$(CC)" "clang"
- CFLAGS += -Wunreachable-code
-@@ -32,7 +32,6 @@ else ifeq "$(build)" "sanitize"
- LDFLAGS += -fsanitize=address
- else
- CFLAGS += -Os
-- LDFLAGS += -Wl,-s
- endif
-
- ifeq "$(HAVE_READLINE)" "yes"
diff --git a/dev-lang/mujs/mujs-1.0.4.ebuild b/dev-lang/mujs/mujs-1.0.4.ebuild
deleted file mode 100644
index cb17cf6855f7..000000000000
--- a/dev-lang/mujs/mujs-1.0.4.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit flag-o-matic multilib toolchain-funcs
-
-DESCRIPTION="lightweight Javascript interpreter"
-HOMEPAGE="http://mujs.com/"
-SRC_URI="https://mujs.com/downloads/${P}.tar.xz"
-
-LICENSE="AGPL-3"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ppc ppc64 s390 sparc x86 ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="static-libs"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.0.4-gentoo.patch
-)
-
-src_prepare() {
- default
- append-cflags -fPIC -Wl,-soname=lib${PN}.so.${PV}
- tc-export CC
-}
-
-src_compile() {
- emake VERSION=${PV} prefix=/usr shared
-}
-
-src_install() {
- emake \
- DESTDIR="${ED}" \
- VERSION=${PV} \
- prefix=/usr \
- libdir="/usr/$(get_libdir)" \
- install-shared \
- $(usex static-libs install-static '')
-
- mv -v "${D}"/usr/$(get_libdir)/lib${PN}.so{,.${PV}} || die
- dosym lib${PN}.so.${PV} /usr/$(get_libdir)/lib${PN}.so || die
- dosym lib${PN}.so.${PV} /usr/$(get_libdir)/lib${PN}.so.${PV:0:1} || die
-}