summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/erlang/erlang-22.1.4.ebuild3
-rw-r--r--dev-lang/erlang/erlang-22.1.8-r1.ebuild3
-rw-r--r--dev-lang/erlang/erlang-22.2.1-r1.ebuild3
-rw-r--r--dev-lang/erlang/erlang-22.2.2.ebuild1
-rw-r--r--dev-lang/erlang/erlang-22.2.ebuild3
-rw-r--r--dev-lang/erlang/files/erlang-22.1.4-asn1-dep.patch15
6 files changed, 24 insertions, 4 deletions
diff --git a/dev-lang/erlang/erlang-22.1.4.ebuild b/dev-lang/erlang/erlang-22.1.4.ebuild
index 83d78ce48e10..a6aec6a1a12f 100644
--- a/dev-lang/erlang/erlang-22.1.4.ebuild
+++ b/dev-lang/erlang/erlang-22.1.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -51,6 +51,7 @@ S="${WORKDIR}/otp-OTP-${PV}"
PATCHES=(
"${FILESDIR}/18.2.1-wx3.0.patch"
"${FILESDIR}/${PN}-22.0-dont-ignore-LDFLAGS.patch"
+ "${FILESDIR}/${PN}-22.1.4-asn1-dep.patch"
)
SITEFILE=50"${PN}"-gentoo.el
diff --git a/dev-lang/erlang/erlang-22.1.8-r1.ebuild b/dev-lang/erlang/erlang-22.1.8-r1.ebuild
index 3ffd63edd06e..5d1d119a7576 100644
--- a/dev-lang/erlang/erlang-22.1.8-r1.ebuild
+++ b/dev-lang/erlang/erlang-22.1.8-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -51,6 +51,7 @@ S="${WORKDIR}/otp-OTP-${PV}"
PATCHES=(
"${FILESDIR}/18.2.1-wx3.0.patch"
"${FILESDIR}/${PN}-22.0-dont-ignore-LDFLAGS.patch"
+ "${FILESDIR}/${PN}-22.1.4-asn1-dep.patch"
)
SITEFILE=50"${PN}"-gentoo.el
diff --git a/dev-lang/erlang/erlang-22.2.1-r1.ebuild b/dev-lang/erlang/erlang-22.2.1-r1.ebuild
index 3ffd63edd06e..5d1d119a7576 100644
--- a/dev-lang/erlang/erlang-22.2.1-r1.ebuild
+++ b/dev-lang/erlang/erlang-22.2.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -51,6 +51,7 @@ S="${WORKDIR}/otp-OTP-${PV}"
PATCHES=(
"${FILESDIR}/18.2.1-wx3.0.patch"
"${FILESDIR}/${PN}-22.0-dont-ignore-LDFLAGS.patch"
+ "${FILESDIR}/${PN}-22.1.4-asn1-dep.patch"
)
SITEFILE=50"${PN}"-gentoo.el
diff --git a/dev-lang/erlang/erlang-22.2.2.ebuild b/dev-lang/erlang/erlang-22.2.2.ebuild
index 97a529061f4c..c52ed00f231a 100644
--- a/dev-lang/erlang/erlang-22.2.2.ebuild
+++ b/dev-lang/erlang/erlang-22.2.2.ebuild
@@ -52,6 +52,7 @@ PATCHES=(
"${FILESDIR}/18.2.1-wx3.0.patch"
"${FILESDIR}/${PN}-22.0-dont-ignore-LDFLAGS.patch"
"${FILESDIR}/${PN}-22.2.2-gcc-10.patch"
+ "${FILESDIR}/${PN}-22.1.4-asn1-dep.patch"
)
SITEFILE=50"${PN}"-gentoo.el
diff --git a/dev-lang/erlang/erlang-22.2.ebuild b/dev-lang/erlang/erlang-22.2.ebuild
index 3ffd63edd06e..5d1d119a7576 100644
--- a/dev-lang/erlang/erlang-22.2.ebuild
+++ b/dev-lang/erlang/erlang-22.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -51,6 +51,7 @@ S="${WORKDIR}/otp-OTP-${PV}"
PATCHES=(
"${FILESDIR}/18.2.1-wx3.0.patch"
"${FILESDIR}/${PN}-22.0-dont-ignore-LDFLAGS.patch"
+ "${FILESDIR}/${PN}-22.1.4-asn1-dep.patch"
)
SITEFILE=50"${PN}"-gentoo.el
diff --git a/dev-lang/erlang/files/erlang-22.1.4-asn1-dep.patch b/dev-lang/erlang/files/erlang-22.1.4-asn1-dep.patch
new file mode 100644
index 000000000000..84c9b81ad770
--- /dev/null
+++ b/dev-lang/erlang/files/erlang-22.1.4-asn1-dep.patch
@@ -0,0 +1,15 @@
+https://bugs.gentoo.org/705500
+https://github.com/erlang/otp/pull/2508
+
+--- a/lib/asn1/src/Makefile
++++ b/lib/asn1/src/Makefile
+@@ -190,7 +190,8 @@ asn1rtt_%.$(EMULATOR): asn1rtt_%.erl
+ $(V_ERLC) +debug_info $<
+
+ $(EVAL_CT_MODULES:%=%.erl): prepare_templates.$(EMULATOR) \
+- $(EBIN)/asn1ct_rtt.$(EMULATOR)
++ $(EBIN)/asn1ct_rtt.$(EMULATOR) \
++ $(EBIN)/asn1ct_func.$(EMULATOR)
+
+ #
+ # Dependencies