summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/boost-numpy/boost-numpy-9999.ebuild')
-rw-r--r--dev-libs/boost-numpy/boost-numpy-9999.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-libs/boost-numpy/boost-numpy-9999.ebuild b/dev-libs/boost-numpy/boost-numpy-9999.ebuild
new file mode 100644
index 000000000000..b3e60b390972
--- /dev/null
+++ b/dev-libs/boost-numpy/boost-numpy-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Boost.Python interface for NumPy"
+HOMEPAGE="https://github.com/ndarray/Boost.NumPy"
+if [ ${PV} == 9999 ]; then
+ inherit git-2
+ EGIT_REPO_URI="git://github.com/ndarray/Boost.NumPy.git \
+ https://github.com/ndarray/Boost.NumPy.git"
+else
+ SRC_URI="http://dev.gentoo.org/~heroxbd/${P}.tar.xz"
+fi
+
+LICENSE="Boost-1.0"
+SLOT=0
+IUSE="doc examples"
+KEYWORDS=""
+
+CDEPEND="dev-python/numpy
+ dev-libs/boost[python]"
+DEPEND="${CDEPEND}"
+RDEPEND="${CDEPEND}"
+
+src_install() {
+ cmake-utils_src_install
+
+ use doc && dodoc -r libs/numpy/doc/*
+ use examples && dodoc -r libs/numpy/example
+}