summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/boost')
-rw-r--r--dev-libs/boost/boost-1.55.0-r2.ebuild17
1 files changed, 15 insertions, 2 deletions
diff --git a/dev-libs/boost/boost-1.55.0-r2.ebuild b/dev-libs/boost/boost-1.55.0-r2.ebuild
index a9e1cda0b597..a3aa6bf5a5b9 100644
--- a/dev-libs/boost/boost-1.55.0-r2.ebuild
+++ b/dev-libs/boost/boost-1.55.0-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -75,7 +75,20 @@ create_user-config.jam() {
fi
if python_bindings_needed; then
- python_configuration="using python : : ${PYTHON} ;"
+ # boost expects libpython$(pyver) and doesn't allow overrides
+ # and the build system is so creepy that it's easier just to
+ # provide a symlink (linker's going to use SONAME anyway)
+ # TODO: replace it with proper override one day
+ ln -f -s "$(python_get_library_path)" "${T}/lib${EPYTHON}$(get_libname)" || die
+
+ if tc-is-cross-compiler; then
+ python_configuration="using python : ${EPYTHON#python} : : ${SYSROOT:-${EROOT}}/usr/include/${EPYTHON} : ${SYSROOT:-${EROOT}}/usr/$(get_libdir) ;"
+ else
+ # note: we need to provide version explicitly because of
+ # a bug in the build system:
+ # https://github.com/boostorg/build/pull/104
+ python_configuration="using python : ${EPYTHON#python} : ${PYTHON} : $(python_get_includedir) : ${T} ;"
+ fi
fi
cat > "${BOOST_ROOT}/user-config.jam" << __EOF__