summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/gom/gom-0.3.1.ebuild')
-rw-r--r--dev-libs/gom/gom-0.3.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/gom/gom-0.3.1.ebuild b/dev-libs/gom/gom-0.3.1.ebuild
new file mode 100644
index 000000000000..340b4f192f52
--- /dev/null
+++ b/dev-libs/gom/gom-0.3.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="yes"
+
+inherit gnome2
+
+DESCRIPTION="GObject to SQLite object mapper library"
+HOMEPAGE="https://wiki.gnome.org/Projects/Gom"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+
+IUSE="+introspection test"
+KEYWORDS="~alpha amd64 ~ppc ~ppc64 ~sparc x86"
+
+RDEPEND="
+ >=dev-db/sqlite-3.7:3
+ >=dev-libs/glib-2.36:2
+ introspection? ( >=dev-libs/gobject-introspection-1.30.0 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.14
+ >=dev-util/intltool-0.40.0
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? ( x11-libs/gdk-pixbuf )
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable introspection) \
+ $(use_enable test glibtest)
+}