summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/jansson/jansson-2.4.ebuild')
-rw-r--r--dev-libs/jansson/jansson-2.4.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-libs/jansson/jansson-2.4.ebuild b/dev-libs/jansson/jansson-2.4.ebuild
new file mode 100644
index 000000000000..f07d058bda58
--- /dev/null
+++ b/dev-libs/jansson/jansson-2.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils
+
+DESCRIPTION="C library for encoding, decoding and manipulating JSON data"
+HOMEPAGE="http://www.digip.org/jansson/"
+SRC_URI="http://www.digip.org/jansson/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 arm ppc ppc64 x86"
+IUSE="doc static-libs"
+
+DEPEND="doc? ( >=dev-python/sphinx-1.0.4 )"
+RDEPEND=""
+
+DOCS=(CHANGES README.rst)
+
+src_prepare() {
+ sed -ie 's/-Werror//' src/Makefile.am || die
+ autotools-utils_src_prepare
+}
+
+src_compile() {
+ autotools-utils_src_compile
+
+ use doc && autotools-utils_src_compile html
+}
+
+src_install() {
+ use doc && HTML_DOCS=("${AUTOTOOLS_BUILD_DIR}/doc/_build/html/")
+ autotools-utils_src_install
+}