summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libexecinfo/libexecinfo-1.1.ebuild')
-rw-r--r--dev-libs/libexecinfo/libexecinfo-1.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-libs/libexecinfo/libexecinfo-1.1.ebuild b/dev-libs/libexecinfo/libexecinfo-1.1.ebuild
new file mode 100644
index 000000000000..c35eb64da08c
--- /dev/null
+++ b/dev-libs/libexecinfo/libexecinfo-1.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit bsdmk freebsd multilib
+
+DESCRIPTION="A library for inspecting program's backtrace"
+HOMEPAGE="http://www.freebsdsoftware.org/devel/libexecinfo.html"
+SRC_URI="mirror://freebsd/distfiles/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+DEPEND="sys-freebsd/freebsd-mk-defs"
+RDEPEND=""
+
+PATCHES=( "${FILESDIR}/${P}-build.patch" )
+
+src_install() {
+ mymakeopts="${mymakeopts} LIBDIR=/usr/$(get_libdir)"
+ freebsd_src_install
+ dodoc README
+}