summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libstrl')
-rw-r--r--dev-libs/libstrl/libstrl-0.5.1-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-libs/libstrl/libstrl-0.5.1-r1.ebuild b/dev-libs/libstrl/libstrl-0.5.1-r1.ebuild
new file mode 100644
index 000000000000..a3d8d099ada1
--- /dev/null
+++ b/dev-libs/libstrl/libstrl-0.5.1-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs multilib-minimal
+
+DESCRIPTION="Compat library for functions like strlcpy(), strlcat(), strnlen(), getline()"
+HOMEPAGE="http://ohnopub.net/~ohnobinki/libstrl/"
+SRC_URI="ftp://mirror.ohnopub.net/mirror/${P}.tar.bz2"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x64-macos"
+IUSE="doc static-libs test"
+
+DEPEND="
+ doc? ( app-doc/doxygen )
+ test? ( dev-libs/check )
+"
+
+src_prepare() {
+ default
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ tc-export AR
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with doc doxygen) \
+ $(use_with test check)
+}