summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libtasn1/libtasn1-4.6.ebuild')
-rw-r--r--dev-libs/libtasn1/libtasn1-4.6.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-libs/libtasn1/libtasn1-4.6.ebuild b/dev-libs/libtasn1/libtasn1-4.6.ebuild
new file mode 100644
index 000000000000..00b5a07c6c5f
--- /dev/null
+++ b/dev-libs/libtasn1/libtasn1-4.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools-multilib
+
+DESCRIPTION="ASN.1 library"
+HOMEPAGE="https://www.gnu.org/software/libtasn1/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3 LGPL-2.1"
+SLOT="0/6" # subslot = libtasn1 soname version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc static-libs"
+
+DEPEND=">=dev-lang/perl-5.6
+ sys-apps/help2man
+ virtual/yacc"
+RDEPEND="
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-baselibs-20131008-r16
+ !app-emulation/emul-linux-x86-baselibs[-abi_x86_32(-)]
+ )"
+
+DOCS=( AUTHORS ChangeLog NEWS README THANKS )
+
+src_configure() {
+ local myeconfargs
+ [[ "${VALGRIND_TESTS}" == "0" ]] && myeconfargs+=( --disable-valgrind-tests )
+ autotools-multilib_src_configure
+}
+
+src_install() {
+ autotools-multilib_src_install
+
+ if use doc ; then
+ dodoc doc/libtasn1.pdf
+ dohtml doc/reference/html/*
+ fi
+}