summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libzip/libzip-1.0.1.ebuild')
-rw-r--r--dev-libs/libzip/libzip-1.0.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-libs/libzip/libzip-1.0.1.ebuild b/dev-libs/libzip/libzip-1.0.1.ebuild
new file mode 100644
index 000000000000..4b842e7c766f
--- /dev/null
+++ b/dev-libs/libzip/libzip-1.0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_IN_SOURCE_BUILD=1
+inherit autotools-utils
+
+DESCRIPTION="Library for manipulating zip archives"
+HOMEPAGE="http://www.nih.at/libzip/"
+SRC_URI="http://www.nih.at/libzip/${P}.tar.xz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="static-libs"
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+"
+
+DOCS=( AUTHORS NEWS README THANKS )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.11.2-headers.patch"
+)