summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/mps/mps-1.111.0.ebuild')
-rw-r--r--dev-libs/mps/mps-1.111.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-libs/mps/mps-1.111.0.ebuild b/dev-libs/mps/mps-1.111.0.ebuild
new file mode 100644
index 000000000000..4bb6e3d9e8a9
--- /dev/null
+++ b/dev-libs/mps/mps-1.111.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Ravenbrook Memory Pool System"
+
+MY_P="${PN}-kit-${PV}"
+HOMEPAGE="http://www.ravenbrook.com/project/mps/"
+SRC_URI="http://www.ravenbrook.com/project/${PN}/release/${PV}/${MY_P}.tar.gz"
+
+LICENSE="Sleepycat"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}/
+
+src_prepare() {
+ # need to fix CFLAGS, it's still being silly
+ sed -i -e 's/-Werror//' code/g{c,p}.gmk || die "Failed to fix CFLAGS"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}