summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/boost/boost-1.70.0.ebuild5
-rw-r--r--dev-libs/boost/files/boost-1.70.0-fix-python-cmake-duplicate-target.patch33
2 files changed, 4 insertions, 34 deletions
diff --git a/dev-libs/boost/boost-1.70.0.ebuild b/dev-libs/boost/boost-1.70.0.ebuild
index 6d40a9f70544..68a0140f7781 100644
--- a/dev-libs/boost/boost-1.70.0.ebuild
+++ b/dev-libs/boost/boost-1.70.0.ebuild
@@ -51,7 +51,6 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.48.0-disable_icu_rpath.patch
"${FILESDIR}"/${PN}-1.69.0-context-x32.patch
"${FILESDIR}"/${PN}-1.56.0-build-auto_index-tool.patch
- "${FILESDIR}"/${PN}-1.70.0-fix-python-cmake-duplicate-target.patch
)
python_bindings_needed() {
@@ -174,6 +173,10 @@ src_configure() {
--boost-build="${EPREFIX}"/usr/share/boost-build
--prefix="${ED}/usr"
--layout=system
+ # CMake has issues working with multiple python impls,
+ # disable cmake config generation for the time being
+ # https://github.com/boostorg/python/issues/262#issuecomment-483069294
+ --no-cmake-config
# building with threading=single is currently not possible
# https://svn.boost.org/trac/boost/ticket/7105
threading=multi
diff --git a/dev-libs/boost/files/boost-1.70.0-fix-python-cmake-duplicate-target.patch b/dev-libs/boost/files/boost-1.70.0-fix-python-cmake-duplicate-target.patch
deleted file mode 100644
index c0097a8581bd..000000000000
--- a/dev-libs/boost/files/boost-1.70.0-fix-python-cmake-duplicate-target.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-Boost.Build errors out when passing multiple python impls to b2:
-
- error: Name clash for '<p/var/tmp/portage/dev-libs/boost-1.70.0/image/usr/lib64/cmake/boost_python-1.70.0>libboost_python-variant-shared.cmake'
- error:
- error: Tried to build the target twice, with property sets having
- error: these incompatible properties:
- error:
- error: - <python>2.7
- error: - <python>3.6
- error:
- error: Please make sure to have consistent requirements for these
- error: properties everywhere in your project, especially for install
- error: targets.
-
-https://github.com/boostorg/python/issues/262
-
---- a/tools/boost_install/boost-install.jam
-+++ b/tools/boost_install/boost-install.jam
-@@ -870,12 +870,12 @@
-
- $(p).mark-target-as-explicit install-libraries ;
-
-- install-cmake-config $(libraries) ;
-+ # install-cmake-config $(libraries) ;
-
- generate install-dependencies : $(libraries) : <generating-rule>@boost-install%generate-dependencies <name>install ;
- $(p).mark-target-as-explicit install-dependencies ;
-
-- alias install : install-libraries install-cmake-config install-dependencies ;
-+ alias install : install-libraries install-dependencies ;
- $(p).mark-target-as-explicit install ;
-
- # Target stage