summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lua/say/say-1.3_p1.ebuild')
-rw-r--r--dev-lua/say/say-1.3_p1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-lua/say/say-1.3_p1.ebuild b/dev-lua/say/say-1.3_p1.ebuild
new file mode 100644
index 000000000000..ff54acc4cd4e
--- /dev/null
+++ b/dev-lua/say/say-1.3_p1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+MY_PV=1.3-1
+
+inherit toolchain-funcs
+
+DESCRIPTION="Lua String Hashing/Indexing Library"
+HOMEPAGE="http://olivinelabs.com/busted/"
+SRC_URI="https://github.com/Olivine-Labs/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+COMMON_DEPEND=">=dev-lang/lua-5.1:="
+DEPEND="${COMMON_DEPEND}
+virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_install() {
+ insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)"/${PN}
+doins src/init.lua
+dodoc CONTRIBUTING.md README.md
+}