summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/luvit/Manifest1
-rw-r--r--dev-lua/luvit/luvit-0.7.0.ebuild93
2 files changed, 0 insertions, 94 deletions
diff --git a/dev-lua/luvit/Manifest b/dev-lua/luvit/Manifest
index 7313be14c391..53fa5863bb53 100644
--- a/dev-lua/luvit/Manifest
+++ b/dev-lua/luvit/Manifest
@@ -1,2 +1 @@
-DIST luvit-0.7.0.tar.gz 6440621 BLAKE2B 03cde753f19441bf408c3985704d9042bdbb217368d2effdb494c650038dd2f6a01acd81a73c8bd6e2ef5648d017eb27a8728f4ea568d62f9a94812cf19fe767 SHA512 9a2366d7033f685bdaed9d8fc22b74e570a6b2b5f0c2e5ecdea6b92776e12fed7ec8fa6c84ff457bdfc8849a7ee79c27803577857b3263e20c1fc53b87383b12
DIST luvit-0.8.2.tar.gz 7126452 BLAKE2B fc08b9964883ad0708cfeec0740171936daa8e58b43ff587eecbe3986f86e46d850a67b47e7a14880c67b9abe650b5cac3bcffab1c6fb2a42f965f38663aa292 SHA512 46ce9e99d1a002697bb777000d97849135805c3b36344880c1d5cb48c648c7252ec440af35a78eb595d7706d11dc85f76e72c72569e2b3d26e2747b870f98c2b
diff --git a/dev-lua/luvit/luvit-0.7.0.ebuild b/dev-lua/luvit/luvit-0.7.0.ebuild
deleted file mode 100644
index c36395406c9d..000000000000
--- a/dev-lua/luvit/luvit-0.7.0.ebuild
+++ /dev/null
@@ -1,93 +0,0 @@
-# Copyright 1999-2018 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils toolchain-funcs multilib
-
-# TODO: FHS https://github.com/luvit/luvit/issues/379
-
-DESCRIPTION="Takes node.js' architecture and dependencies and fits it in the Lua language"
-HOMEPAGE="https://luvit.io/"
-SRC_URI="https://luvit.io/dist/latest/${P}.tar.gz"
-
-KEYWORDS="amd64 x86"
-SLOT="0"
-IUSE="bundled-libs examples"
-# luvit Apache-2.0
-# luajit MIT
-# yajl BSD
-LICENSE="Apache-2.0 bundled-libs? ( BSD MIT )"
-
-# fails in portage environment
-# succeeds if run manually
-RESTRICT="test"
-
-RDEPEND="
- dev-libs/openssl:0
- sys-libs/zlib
- !bundled-libs? (
- dev-lang/luajit:2[lua52compat]
- >=dev-libs/yajl-2.0.2
- net-libs/http-parser:=
- )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_prepare() {
- rm -r deps/{openssl,zlib} || die
- epatch "${FILESDIR}"/${P}-unbundle-http-parser.patch
- if use bundled-libs ; then
- sed -i \
- -e "s/-Werror//" \
- -e "s/-O3//" \
- deps/http-parser/Makefile || die "fixing flags failed!"
- else
- rm -r deps/{luajit,yajl,http-parser} || die
- # TODO: no version detection for http-parser yet
- MY_YAJL_VERSION=$($(tc-getPKG_CONFIG) --modversion yajl)
- MY_LUAJIT_VERSION=$($(tc-getPKG_CONFIG) --modversion luajit)
- sed -i \
- -e "s:^YAJL_VERSION=.*:YAJL_VERSION=${MY_YAJL_VERSION}:" \
- -e "s:^LUAJIT_VERSION=.*:LUAJIT_VERSION=${MY_LUAJIT_VERSION}:" \
- Makefile || die "setting yajl version failed"
- fi
-
-}
-
-src_configure() {
- # skip retarded gyp build system
- :
-}
-
-src_compile() {
- tc-export CC AR
-
- emake -C deps/cares
-
- myemakeargs=(
- DEBUG=0
- WERROR=0
- USE_SYSTEM_SSL=1
- # bundled luajit is compiled with special flags
- USE_SYSTEM_LUAJIT=$(usex bundled-libs "0" "1")
- USE_SYSTEM_YAJL=$(usex bundled-libs "0" "1")
- USE_SYSTEM_HTTPPARSER=$(usex bundled-libs "0" "1")
- USE_SYSTEM_ZLIB=1
- PREFIX=/usr
- LIBDIR="${D%/}"/usr/$(get_libdir)/${PN}
- DESTDIR="${D}"
- )
-
- emake "${myemakeargs[@]}" all
-}
-
-src_install() {
- emake "${myemakeargs[@]}" install
- dodoc TODO ChangeLog README.markdown errors.markdown
-
- if use examples ; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}