summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/bin-prot/bin-prot-112.24.00.ebuild')
-rw-r--r--dev-ml/bin-prot/bin-prot-112.24.00.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ml/bin-prot/bin-prot-112.24.00.ebuild b/dev-ml/bin-prot/bin-prot-112.24.00.ebuild
new file mode 100644
index 000000000000..78442d745fcf
--- /dev/null
+++ b/dev-ml/bin-prot/bin-prot-112.24.00.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_TESTS=1
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="A binary protocol generator"
+HOMEPAGE="http://ocaml.janestreet.com/?q=node/13"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${MY_P%.*}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+RDEPEND=">=dev-ml/type-conv-109.28.00:=
+ dev-ml/camlp4:="
+DEPEND="${RDEPEND}
+ test? ( >=dev-ml/ounit-1.1.2 )"
+
+DOCS=( "README.md" "CHANGES.md" )
+S="${WORKDIR}/${MY_P}"