summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/camlpdf/camlpdf-2.1.1.ebuild')
-rw-r--r--dev-ml/camlpdf/camlpdf-2.1.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ml/camlpdf/camlpdf-2.1.1.ebuild b/dev-ml/camlpdf/camlpdf-2.1.1.ebuild
new file mode 100644
index 000000000000..83226661473c
--- /dev/null
+++ b/dev-ml/camlpdf/camlpdf-2.1.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="OCaml library for reading, writing, and modifying PDF files"
+HOMEPAGE="https://github.com/johnwhitington/camlpdf/"
+SRC_URI="https://github.com/johnwhitington/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+# technically LGPL-2.1+ with linking exception
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="dev-lang/ocaml:="
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ # parallel make bugs
+ emake -j1
+}
+
+src_install() {
+ findlib_src_install
+ dodoc Changes README.md
+
+ if use doc ; then
+ dodoc introduction_to_camlpdf.pdf
+ dohtml doc/camlpdf/html/*
+ fi
+
+ use examples && dodoc -r examples
+}