summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/capnp-ocaml')
-rw-r--r--dev-ml/capnp-ocaml/Manifest1
-rw-r--r--dev-ml/capnp-ocaml/capnp-ocaml-2.1.1.ebuild43
-rw-r--r--dev-ml/capnp-ocaml/files/mi.patch31
-rw-r--r--dev-ml/capnp-ocaml/metadata.xml8
4 files changed, 83 insertions, 0 deletions
diff --git a/dev-ml/capnp-ocaml/Manifest b/dev-ml/capnp-ocaml/Manifest
new file mode 100644
index 000000000000..c751b113fede
--- /dev/null
+++ b/dev-ml/capnp-ocaml/Manifest
@@ -0,0 +1 @@
+DIST capnp-ocaml-2.1.1.tar.gz 189731 SHA256 b4718b650c51ba05292afcbd1cb0ddfbd3efc7e160c65736538434b76c9cd931 SHA512 79083c2f387d6055a2cab45230b97f579a727418d55be13d3ca0135efd8561787b772012ed7f6f3277f9a34df3cb4684242bd754e048fbe77e4c8ba8ff9faf93 WHIRLPOOL c7b697cc8a2e2d26900a2845140d302da8b81aa5cdd8cfc0fd1ff95b8193b3f51185e7da3275b76582d98a7b03808c21e7eafb98d55e3d9ac700aac0ac614f68
diff --git a/dev-ml/capnp-ocaml/capnp-ocaml-2.1.1.ebuild b/dev-ml/capnp-ocaml/capnp-ocaml-2.1.1.ebuild
new file mode 100644
index 000000000000..2509cac727f9
--- /dev/null
+++ b/dev-ml/capnp-ocaml/capnp-ocaml-2.1.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="OCaml code generator plugin for the Cap'n Proto serialization framework"
+HOMEPAGE="https://github.com/pelzlpj/capnp-ocaml"
+SRC_URI="https://github.com/pelzlpj/capnp-ocaml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-lang/ocaml:=[ocamlopt]
+ dev-ml/core_kernel:=
+ dev-ml/camlp4:=
+ dev-ml/ocaml-extunix:=
+ dev-ml/ocplib-endian:=
+ dev-ml/res:=
+ dev-ml/ocaml-uint:=
+"
+DEPEND="${RDEPEND}
+ dev-util/omake
+"
+
+src_prepare() {
+ epatch "${FILESDIR}/mi.patch"
+}
+
+src_compile() {
+ PREFIX="${EPREFIX}/usr" omake --force-dotomake || die
+}
+
+src_install() {
+ findlib_src_preinst
+ DESTDIR="${D}" PREFIX="${EPREFIX}/usr" omake --force-dotomake install || die
+ dodoc README.adoc CHANGELOG.adoc
+}
diff --git a/dev-ml/capnp-ocaml/files/mi.patch b/dev-ml/capnp-ocaml/files/mi.patch
new file mode 100644
index 000000000000..f7e1625c6ddb
--- /dev/null
+++ b/dev-ml/capnp-ocaml/files/mi.patch
@@ -0,0 +1,31 @@
+Index: capnp-ocaml-2.1.1/src/compiler/OMakefile
+===================================================================
+--- capnp-ocaml-2.1.1.orig/src/compiler/OMakefile
++++ capnp-ocaml-2.1.1/src/compiler/OMakefile
+@@ -24,7 +24,8 @@ else
+
+ includes.ml: make_includes.ml ../runtime/common-inc.ml \
+ ../runtime/reader-inc.ml ../runtime/builder-inc.ml
+- ocaml $(TOPLEVEL_INCLUDE) make_includes.ml
++ ocamlfind ocamlopt -o make_includes -package core_kernel -linkpkg make_includes.ml
++ ./make_includes
+
+
+ PROGRAM = capnpc-ocaml
+Index: capnp-ocaml-2.1.1/src/compiler/make_includes.ml
+===================================================================
+--- capnp-ocaml-2.1.1.orig/src/compiler/make_includes.ml
++++ capnp-ocaml-2.1.1/src/compiler/make_includes.ml
+@@ -1,12 +1,7 @@
+-#!/usr/bin/env ocaml
+-
+ (* Generate ocaml code containing the content of a couple of files, formatted
+ as a list of lines. This is used to perform an ocaml source inclusion,
+ providing functor-like capability without the performance hit. *)
+
+-#use "topfind"
+-#require "core_kernel"
+-
+ open Core_kernel
+
+
diff --git a/dev-ml/capnp-ocaml/metadata.xml b/dev-ml/capnp-ocaml/metadata.xml
new file mode 100644
index 000000000000..ffac4d7ebc01
--- /dev/null
+++ b/dev-ml/capnp-ocaml/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+</maintainer>
+</pkgmetadata>