summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/extlib/extlib-1.6.1-r1.ebuild')
-rw-r--r--dev-ml/extlib/extlib-1.6.1-r1.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-ml/extlib/extlib-1.6.1-r1.ebuild b/dev-ml/extlib/extlib-1.6.1-r1.ebuild
deleted file mode 100644
index b7c0f30b3de8..000000000000
--- a/dev-ml/extlib/extlib-1.6.1-r1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit findlib eutils
-
-DESCRIPTION="Standard library extensions for O'Caml"
-HOMEPAGE="https://code.google.com/p/ocaml-extlib/"
-SRC_URI="https://ocaml-extlib.googlecode.com/files/${P}.tar.gz"
-LICENSE="LGPL-2.1"
-DEPEND="
- >=dev-lang/ocaml-3.10.2:=[ocamlopt?]
- dev-ml/camlp4:=
-"
-RDEPEND="${DEPEND}"
-SLOT="0/${PV}"
-KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE="doc +ocamlopt"
-
-src_compile() {
- emake -j1 all
- if use ocamlopt; then
- emake opt
- fi
-
- if use doc; then
- emake doc
- fi
-}
-
-src_install () {
- findlib_src_install
-
- # install documentation
- dodoc README.txt
-
- if use doc; then
- dohtml doc/*
- fi
-}