summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/js_of_ocaml')
-rw-r--r--dev-ml/js_of_ocaml/js_of_ocaml-2.8.4.ebuild7
-rw-r--r--dev-ml/js_of_ocaml/js_of_ocaml-9999.ebuild7
-rw-r--r--dev-ml/js_of_ocaml/metadata.xml1
3 files changed, 6 insertions, 9 deletions
diff --git a/dev-ml/js_of_ocaml/js_of_ocaml-2.8.4.ebuild b/dev-ml/js_of_ocaml/js_of_ocaml-2.8.4.ebuild
index 212d6dd40658..a68da44990b4 100644
--- a/dev-ml/js_of_ocaml/js_of_ocaml-2.8.4.ebuild
+++ b/dev-ml/js_of_ocaml/js_of_ocaml-2.8.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -20,12 +20,11 @@ fi
LICENSE="LGPL-2.1-with-linking-exception"
SLOT="0/${PV}"
-IUSE="+async +ocamlopt doc +deriving +ppx +ppx-deriving +react +xml X"
+IUSE="+ocamlopt doc +deriving +ppx +ppx-deriving +react +xml X"
RDEPEND="
>=dev-lang/ocaml-3.12:=[ocamlopt?,X?]
>=dev-ml/lwt-2.4.4:=[camlp4(+)]
- async? ( dev-ml/async_kernel:= )
react? ( dev-ml/react:= dev-ml/reactiveData:= )
xml? ( >=dev-ml/tyxml-4:= )
ppx? ( dev-ml/ppx_tools:= )
@@ -50,7 +49,7 @@ src_configure() {
use react || echo "WITH_REACT := NO" >> Makefile.conf
use ppx || echo "WITH_PPX := NO" >> Makefile.conf
use ppx-deriving || echo "WITH_PPX_PPX_DERIVING := NO" >> Makefile.conf
- use async || echo "WITH_ASYNC := NO" >> Makefile.conf
+ echo "WITH_ASYNC := NO" >> Makefile.conf
}
src_compile() {
diff --git a/dev-ml/js_of_ocaml/js_of_ocaml-9999.ebuild b/dev-ml/js_of_ocaml/js_of_ocaml-9999.ebuild
index 212d6dd40658..a68da44990b4 100644
--- a/dev-ml/js_of_ocaml/js_of_ocaml-9999.ebuild
+++ b/dev-ml/js_of_ocaml/js_of_ocaml-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -20,12 +20,11 @@ fi
LICENSE="LGPL-2.1-with-linking-exception"
SLOT="0/${PV}"
-IUSE="+async +ocamlopt doc +deriving +ppx +ppx-deriving +react +xml X"
+IUSE="+ocamlopt doc +deriving +ppx +ppx-deriving +react +xml X"
RDEPEND="
>=dev-lang/ocaml-3.12:=[ocamlopt?,X?]
>=dev-ml/lwt-2.4.4:=[camlp4(+)]
- async? ( dev-ml/async_kernel:= )
react? ( dev-ml/react:= dev-ml/reactiveData:= )
xml? ( >=dev-ml/tyxml-4:= )
ppx? ( dev-ml/ppx_tools:= )
@@ -50,7 +49,7 @@ src_configure() {
use react || echo "WITH_REACT := NO" >> Makefile.conf
use ppx || echo "WITH_PPX := NO" >> Makefile.conf
use ppx-deriving || echo "WITH_PPX_PPX_DERIVING := NO" >> Makefile.conf
- use async || echo "WITH_ASYNC := NO" >> Makefile.conf
+ echo "WITH_ASYNC := NO" >> Makefile.conf
}
src_compile() {
diff --git a/dev-ml/js_of_ocaml/metadata.xml b/dev-ml/js_of_ocaml/metadata.xml
index 61eb3e1f8706..0b34c19deedf 100644
--- a/dev-ml/js_of_ocaml/metadata.xml
+++ b/dev-ml/js_of_ocaml/metadata.xml
@@ -6,7 +6,6 @@
<name>Gentoo ML Project</name>
</maintainer>
<use>
- <flag name="async">Enable support of <pkg>dev-ml/async_kernel</pkg>.</flag>
<flag name="deriving">Enable <pkg>dev-ml/deriving</pkg> support for improving the type safety.</flag>
<flag name="ppx">Enables the ppx syntax extension</flag>
<flag name="ppx-deriving">Enables deriving support through ppx syntax extensions.</flag>