summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/labltk')
-rw-r--r--dev-ml/labltk/Manifest1
-rw-r--r--dev-ml/labltk/labltk-8.06.9.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-ml/labltk/Manifest b/dev-ml/labltk/Manifest
index 221f5d2bf6b8..da891e7c3cfa 100644
--- a/dev-ml/labltk/Manifest
+++ b/dev-ml/labltk/Manifest
@@ -1,2 +1,3 @@
DIST labltk-8.06.2.tar.gz 369508 BLAKE2B df0a5fb1cf352c52bf3177e83be2cadde961c2a7ba0496f45dc515141931d13715b4c253f74e5f280f9a6c310488236e6bc598c0ceffc408028ef5f524f2bcf2 SHA512 d9342d49ba8769edd7a4ed051844f6ae5d3e62a7c2c76e895bfd1162d0433c4ea54f2314b29b708551fba63daec1123553b56f0abb6412807ab00d7bb40b73d6
DIST labltk-8.06.7.tar.gz 370870 BLAKE2B 2d836c824d9adbd4f03d0e7e81faa51669837eecb4f94f6c89c657966774fe7d6ed928459be3ccca7fd3e7cf67a54ee63f7d2d08dcc8b7e853f5ad64769b33a2 SHA512 3c7352d14bc337adfb1939e72bd2658bb5e60b463f10f3748779084d1b7a6e6225028c775b548e355d69984a8944b91580fa978ff904b20b8b762ba9046f5e7d
+DIST labltk-8.06.9.tar.gz 371504 BLAKE2B 587ff01da120501f85f6d9921e46275858f1e1ce730eef205f9e7d7c64f6d3c0ea701cf832fdb8eb0746e1f0cff1151bccb077641740fb18811473b1553e2940 SHA512 fd6defa302d919f229394c486dcefab110b144534525a87082a27d2cab29c0af4ece3da821098fea25416850ad857f7af979d48790330d62dfb8d8db8f2bf6ca
diff --git a/dev-ml/labltk/labltk-8.06.9.ebuild b/dev-ml/labltk/labltk-8.06.9.ebuild
new file mode 100644
index 000000000000..ce876c58810a
--- /dev/null
+++ b/dev-ml/labltk/labltk-8.06.9.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib eutils
+
+DESCRIPTION="OCaml interface to the Tcl/Tk GUI framework"
+HOMEPAGE="https://garrigue.github.io/labltk/"
+SRC_URI="https://github.com/garrigue/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="QPL-1.0 LGPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+ocamlopt X"
+
+RDEPEND="dev-lang/tk:=
+ >=dev-lang/ocaml-4.11:=[ocamlopt?,X(+)?]"
+DEPEND="${RDEPEND}
+ dev-ml/findlib
+"
+
+PATCHES=(
+ "${FILESDIR}/findlib.patch"
+)
+
+src_configure() {
+ ./configure --use-findlib --verbose $(usex X "--tk-x11" "--tk-no-x11") || die "configure failed!"
+}
+
+src_compile() {
+ emake -j1
+ use ocamlopt && emake -j1 opt
+}
+
+src_install() {
+ findlib_src_preinst
+ dodir /usr/bin
+ emake \
+ INSTALLDIR="${D}$(ocamlc -where)/labltk" \
+ INSTALLBINDIR="${ED}/usr/bin/" \
+ install
+ dodoc Changes README.mlTk
+}