summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/merlin/merlin-3.0.0.ebuild')
-rw-r--r--dev-ml/merlin/merlin-3.0.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/merlin/merlin-3.0.0.ebuild b/dev-ml/merlin/merlin-3.0.0.ebuild
new file mode 100644
index 000000000000..609f9767e4cc
--- /dev/null
+++ b/dev-ml/merlin/merlin-3.0.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit findlib vim-plugin
+
+DESCRIPTION="Context sensitive completion for OCaml in Vim and Emacs"
+HOMEPAGE="https://github.com/ocaml/merlin"
+SRC_URI="https://github.com/ocaml/merlin/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-lang/ocaml:=
+ dev-ml/yojson:=
+"
+RDEPEND="${DEPEND}
+ || ( app-editors/vim[python] app-editors/gvim[python] )"
+
+src_configure() {
+ ./configure \
+ --prefix "${EPREFIX}/usr" \
+ --vimdir "${EPREFIX}//usr/share/vim/vimfiles" \
+ || die
+}
+
+src_install() {
+ default
+}