summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocaml-ctypes/ocaml-ctypes-0.11.1.ebuild')
-rw-r--r--dev-ml/ocaml-ctypes/ocaml-ctypes-0.11.1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ml/ocaml-ctypes/ocaml-ctypes-0.11.1.ebuild b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.11.1.ebuild
new file mode 100644
index 000000000000..d563719db9e5
--- /dev/null
+++ b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.11.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Library for binding to C libraries using pure OCaml"
+HOMEPAGE="https://github.com/ocamllabs/ocaml-ctypes"
+SRC_URI="https://github.com/ocamllabs/ocaml-ctypes/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.02:=[ocamlopt]
+ virtual/libffi
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit )"
+
+src_compile() {
+ emake -j1
+}
+
+src_test() {
+ emake -j1 test
+}
+
+src_install() {
+ findlib_src_install
+ dodoc CHANGES.md README.md
+}