summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocaml-ctypes/ocaml-ctypes-0.9.2.ebuild')
-rw-r--r--dev-ml/ocaml-ctypes/ocaml-ctypes-0.9.2.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-ml/ocaml-ctypes/ocaml-ctypes-0.9.2.ebuild b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.9.2.ebuild
deleted file mode 100644
index d563719db9e5..000000000000
--- a/dev-ml/ocaml-ctypes/ocaml-ctypes-0.9.2.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit findlib
-
-DESCRIPTION="Library for binding to C libraries using pure OCaml"
-HOMEPAGE="https://github.com/ocamllabs/ocaml-ctypes"
-SRC_URI="https://github.com/ocamllabs/ocaml-ctypes/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="test"
-
-RDEPEND="
- >=dev-lang/ocaml-4.02:=[ocamlopt]
- virtual/libffi
-"
-DEPEND="${RDEPEND}
- test? ( dev-ml/ounit )"
-
-src_compile() {
- emake -j1
-}
-
-src_test() {
- emake -j1 test
-}
-
-src_install() {
- findlib_src_install
- dodoc CHANGES.md README.md
-}