summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocaml-mysql/ocaml-mysql-1.1.1.ebuild')
-rw-r--r--dev-ml/ocaml-mysql/ocaml-mysql-1.1.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ml/ocaml-mysql/ocaml-mysql-1.1.1.ebuild b/dev-ml/ocaml-mysql/ocaml-mysql-1.1.1.ebuild
new file mode 100644
index 000000000000..b681c4b7ab60
--- /dev/null
+++ b/dev-ml/ocaml-mysql/ocaml-mysql-1.1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib eutils
+
+IUSE="+ocamlopt"
+
+DESCRIPTION="A package for ocaml that provides access to mysql databases"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/870/${P}.tar.gz"
+HOMEPAGE="http://ocaml-mysql.forge.ocamlcore.org/"
+
+DEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt?]
+ sys-libs/zlib
+ >=virtual/mysql-4.0"
+
+RDEPEND="$DEPEND"
+
+SLOT="0/${PV}"
+LICENSE="LGPL-2"
+KEYWORDS="~amd64 ppc x86"
+
+src_compile()
+{
+ emake all
+ if use ocamlopt; then
+ emake opt
+ fi
+}
+
+src_install()
+{
+ findlib_src_preinst
+ emake install
+
+ dodoc CHANGES README VERSION || die
+}