summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocaml-redis-lwt')
-rw-r--r--dev-ml/ocaml-redis-lwt/Manifest1
-rw-r--r--dev-ml/ocaml-redis-lwt/metadata.xml11
-rw-r--r--dev-ml/ocaml-redis-lwt/ocaml-redis-lwt-0.3.5.ebuild43
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-ml/ocaml-redis-lwt/Manifest b/dev-ml/ocaml-redis-lwt/Manifest
new file mode 100644
index 000000000000..f11560ce6f9b
--- /dev/null
+++ b/dev-ml/ocaml-redis-lwt/Manifest
@@ -0,0 +1 @@
+DIST ocaml-redis-0.3.5.tar.gz 31217 SHA256 f43af830ab9d66619a685fbad471b97bdb5d40a4f2bdf923b76f25d139007d78 SHA512 dfd2779635fddc73ab76cd66943267c3de984edeb471728f8d6d9506cd37e9cf4b1875519c7547b90de80fd876abc7fbe6a4c9c0674fcb6a00bbe91afa6c625d WHIRLPOOL 68b02061b04a247d09fcc91fe4215ffe2bad7d8c3598c62df347da67fd698985a7a97edd3f48bcf9223b1db09cc4984c67910868a793df8cba114362f63044ad
diff --git a/dev-ml/ocaml-redis-lwt/metadata.xml b/dev-ml/ocaml-redis-lwt/metadata.xml
new file mode 100644
index 000000000000..20d1ed52023f
--- /dev/null
+++ b/dev-ml/ocaml-redis-lwt/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">0xffea/ocaml-redis</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-redis-lwt/ocaml-redis-lwt-0.3.5.ebuild b/dev-ml/ocaml-redis-lwt/ocaml-redis-lwt-0.3.5.ebuild
new file mode 100644
index 000000000000..a5e2d5969dd5
--- /dev/null
+++ b/dev-ml/ocaml-redis-lwt/ocaml-redis-lwt-0.3.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Redis bindings for OCaml via Lwt"
+HOMEPAGE="http://0xffea.github.io/ocaml-redis/ https://github.com/0xffea/ocaml-redis/"
+SRC_URI="https://github.com/0xffea/ocaml-redis/archive/${PV}.tar.gz -> ocaml-redis-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-lang/ocaml:=
+ dev-ml/ocaml-redis:=
+ dev-ml/lwt:=
+"
+DEPEND="${RDEPEND}
+ dev-ml/jbuilder
+ dev-ml/opam
+ test? ( dev-ml/ounit )"
+
+S=${WORKDIR}/ocaml-redis-${PV}
+
+src_compile() {
+ jbuilder build -p redis-lwt || die
+}
+
+src_test() {
+ jbuilder runtest || die
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ redis-lwt.install || die
+}