summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ocaml-sqlite3/ocaml-sqlite3-4.0.6.ebuild')
-rw-r--r--dev-ml/ocaml-sqlite3/ocaml-sqlite3-4.0.6.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ml/ocaml-sqlite3/ocaml-sqlite3-4.0.6.ebuild b/dev-ml/ocaml-sqlite3/ocaml-sqlite3-4.0.6.ebuild
new file mode 100644
index 000000000000..c4ac79bc1c30
--- /dev/null
+++ b/dev-ml/ocaml-sqlite3/ocaml-sqlite3-4.0.6.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_TESTS=1
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+MY_PN="sqlite3-ocaml"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A package for ocaml that provides access to SQLite databases"
+HOMEPAGE="http://mmottl.github.io/sqlite3-ocaml/"
+SRC_URI="https://github.com/mmottl/sqlite3-ocaml/releases/download/v${PV}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=dev-db/sqlite-3.3.3
+ >=dev-ml/findlib-1.3.2"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+DOCS=( "AUTHORS.txt" "CHANGES.txt" "README.md" "TODO.md" )