summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/ppx_bin_prot/ppx_bin_prot-113.24.00.ebuild')
-rw-r--r--dev-ml/ppx_bin_prot/ppx_bin_prot-113.24.00.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ml/ppx_bin_prot/ppx_bin_prot-113.24.00.ebuild b/dev-ml/ppx_bin_prot/ppx_bin_prot-113.24.00.ebuild
new file mode 100644
index 000000000000..b807702aa32a
--- /dev/null
+++ b/dev-ml/ppx_bin_prot/ppx_bin_prot-113.24.00.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit oasis
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Generation of bin_prot readers and writers from types"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-ml/ppx_tools:=
+ dev-ml/ppx_core:=
+ dev-ml/ppx_type_conv:=
+ >=dev-ml/bin-prot-113.24.00:=
+ "
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( CHANGES.md )