summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/camlp5/camlp5-7.11.ebuild2
-rw-r--r--dev-ml/extlib/extlib-1.7.1.ebuild4
-rw-r--r--dev-ml/extlib/extlib-1.7.2.ebuild4
-rw-r--r--dev-ml/extlib/extlib-1.7.6.ebuild4
-rw-r--r--dev-ml/facile/facile-1.1.3.ebuild4
-rw-r--r--dev-ml/lablgl/lablgl-1.05-r1.ebuild2
-rw-r--r--dev-ml/lablgtk/lablgtk-2.18.10.ebuild2
-rw-r--r--dev-ml/lablgtk/lablgtk-2.18.5.ebuild4
-rw-r--r--dev-ml/lablgtk/lablgtk-2.18.8-r1.ebuild2
9 files changed, 14 insertions, 14 deletions
diff --git a/dev-ml/camlp5/camlp5-7.11.ebuild b/dev-ml/camlp5/camlp5-7.11.ebuild
index 18e4341dd51c..999ed280a3f6 100644
--- a/dev-ml/camlp5/camlp5-7.11.ebuild
+++ b/dev-ml/camlp5/camlp5-7.11.ebuild
@@ -29,7 +29,7 @@ src_configure() {
-mandir /usr/share/man || die "configure failed"
}
-src_compile(){
+src_compile() {
emake out
if use ocamlopt; then
emake opt
diff --git a/dev-ml/extlib/extlib-1.7.1.ebuild b/dev-ml/extlib/extlib-1.7.1.ebuild
index 33dffa043aaf..6cdb6da3e65f 100644
--- a/dev-ml/extlib/extlib-1.7.1.ebuild
+++ b/dev-ml/extlib/extlib-1.7.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -39,7 +39,7 @@ src_test() {
emake -j1 test
}
-src_install () {
+src_install() {
findlib_src_install
# install documentation
diff --git a/dev-ml/extlib/extlib-1.7.2.ebuild b/dev-ml/extlib/extlib-1.7.2.ebuild
index 4f53ed7d6c4a..87f06dc98481 100644
--- a/dev-ml/extlib/extlib-1.7.2.ebuild
+++ b/dev-ml/extlib/extlib-1.7.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -35,7 +35,7 @@ src_test() {
emake -j1 test
}
-src_install () {
+src_install() {
findlib_src_install
# install documentation
diff --git a/dev-ml/extlib/extlib-1.7.6.ebuild b/dev-ml/extlib/extlib-1.7.6.ebuild
index 54e4c815cc39..f3159e67c8f3 100644
--- a/dev-ml/extlib/extlib-1.7.6.ebuild
+++ b/dev-ml/extlib/extlib-1.7.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -38,7 +38,7 @@ src_test() {
emake -j1 test
}
-src_install () {
+src_install() {
findlib_src_install
# install documentation
diff --git a/dev-ml/facile/facile-1.1.3.ebuild b/dev-ml/facile/facile-1.1.3.ebuild
index 1f3ed1639553..ee8d7e1d75be 100644
--- a/dev-ml/facile/facile-1.1.3.ebuild
+++ b/dev-ml/facile/facile-1.1.3.ebuild
@@ -37,7 +37,7 @@ src_prepare() {
fi
}
-src_configure(){
+src_configure() {
# This is a custom configure script and it does not support standard options
./configure --faciledir "${D}"$(ocamlc -where)/facile/ || die
}
@@ -46,7 +46,7 @@ src_test() {
emake check
}
-src_install(){
+src_install() {
dodir $(ocamlc -where)
emake install
einstalldocs
diff --git a/dev-ml/lablgl/lablgl-1.05-r1.ebuild b/dev-ml/lablgl/lablgl-1.05-r1.ebuild
index cd31010997bd..c4e56182d865 100644
--- a/dev-ml/lablgl/lablgl-1.05-r1.ebuild
+++ b/dev-ml/lablgl/lablgl-1.05-r1.ebuild
@@ -69,7 +69,7 @@ src_compile() {
fi
}
-src_install () {
+src_install() {
# Makefile do not use mkdir so the library is not installed
# but copied as a 'stublibs' file.
dodir /usr/$(get_libdir)/ocaml/stublibs
diff --git a/dev-ml/lablgtk/lablgtk-2.18.10.ebuild b/dev-ml/lablgtk/lablgtk-2.18.10.ebuild
index 19f3fac81a81..4cbb3b17630c 100644
--- a/dev-ml/lablgtk/lablgtk-2.18.10.ebuild
+++ b/dev-ml/lablgtk/lablgtk-2.18.10.ebuild
@@ -55,7 +55,7 @@ src_compile() {
fi
}
-src_install () {
+src_install() {
local destdir="$(ocamlfind printconf destdir || die)"
dodir "${destdir}/stublibs"
export OCAMLFIND_DESTDIR=${ED}"${destdir}"
diff --git a/dev-ml/lablgtk/lablgtk-2.18.5.ebuild b/dev-ml/lablgtk/lablgtk-2.18.5.ebuild
index e582427e9c8a..8cfdfda4cf9c 100644
--- a/dev-ml/lablgtk/lablgtk-2.18.5.ebuild
+++ b/dev-ml/lablgtk/lablgtk-2.18.5.ebuild
@@ -63,7 +63,7 @@ install_examples() {
docompress -x /usr/share/doc/${PF}/examples
}
-src_install () {
+src_install() {
findlib_src_preinst
export OCAMLPATH="${OCAMLFIND_DESTDIR}"
emake install DESTDIR="${D}"
@@ -74,7 +74,7 @@ src_install () {
use examples && install_examples
}
-pkg_postinst () {
+pkg_postinst() {
if use examples; then
elog "To run the examples you can use the lablgtk2 toplevel."
elog "e.g: lablgtk2 /usr/share/doc/${PF}/examples/testgtk.ml"
diff --git a/dev-ml/lablgtk/lablgtk-2.18.8-r1.ebuild b/dev-ml/lablgtk/lablgtk-2.18.8-r1.ebuild
index bed3712e2d4b..d1e17c9dd1b2 100644
--- a/dev-ml/lablgtk/lablgtk-2.18.8-r1.ebuild
+++ b/dev-ml/lablgtk/lablgtk-2.18.8-r1.ebuild
@@ -55,7 +55,7 @@ src_compile() {
fi
}
-src_install () {
+src_install() {
local destdir="$(ocamlfind printconf destdir || die)"
dodir "${destdir}/stublibs"
export OCAMLFIND_DESTDIR=${ED}"${destdir}"