summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/uchar/Manifest1
-rw-r--r--dev-ml/uchar/metadata.xml8
-rw-r--r--dev-ml/uchar/uchar-0.0.1.ebuild37
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-ml/uchar/Manifest b/dev-ml/uchar/Manifest
new file mode 100644
index 000000000000..da50db178017
--- /dev/null
+++ b/dev-ml/uchar/Manifest
@@ -0,0 +1 @@
+DIST uchar-0.0.1.tar.gz 23471 SHA256 ac94116a35cbcf346c94b4326d03d382560fbae337b7a59794ad6e1a1a84c140 SHA512 6bdc3646cb959af1a289e22f5202da2f3e3462b42a563ec4a999e96ba7b2d0c95e2d42ef06b35cd9c477eebfadef5bba4abdb60997faa7e6848aa6bcb5d729c2 WHIRLPOOL 7b043985fdc61aac63b1ba923006b40ef52552c0aad5f45d6be6f744b6d1cb1a7ce46d5dc647e59cd82fa5d243a8699bd44987871ef6c60874a31f231c36d2aa
diff --git a/dev-ml/uchar/metadata.xml b/dev-ml/uchar/metadata.xml
new file mode 100644
index 000000000000..ffac4d7ebc01
--- /dev/null
+++ b/dev-ml/uchar/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>Gentoo ML Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-ml/uchar/uchar-0.0.1.ebuild b/dev-ml/uchar/uchar-0.0.1.ebuild
new file mode 100644
index 000000000000..2cf183d878ed
--- /dev/null
+++ b/dev-ml/uchar/uchar-0.0.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DESCRIPTION="Uchar compatibility library"
+HOMEPAGE="https://github.com/ocaml/uchar"
+SRC_URI="https://github.com/ocaml/uchar/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+RDEPEND="dev-lang/ocaml:="
+DEPEND="${RDEPEND}
+ dev-ml/opam"
+
+src_compile() {
+ ocaml pkg/build.ml \
+ "native=$(usex ocamlopt true false)" \
+ "native-dynlink=$(usex ocamlopt true false)" || die
+}
+
+src_test() {
+ ocamlbuild -X src -use-ocamlfind -pkg uchar test/testpkg.native || die
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+ dodoc README.md CHANGES.md
+}