summaryrefslogtreecommitdiff
path: root/dev-ml
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml')
-rw-r--r--dev-ml/ojquery/ojquery-0.1.ebuild14
-rw-r--r--dev-ml/ojquery/ojquery-9999.ebuild2
2 files changed, 12 insertions, 4 deletions
diff --git a/dev-ml/ojquery/ojquery-0.1.ebuild b/dev-ml/ojquery/ojquery-0.1.ebuild
index c94eccbb5981..123a47477ebb 100644
--- a/dev-ml/ojquery/ojquery-0.1.ebuild
+++ b/dev-ml/ojquery/ojquery-0.1.ebuild
@@ -7,12 +7,20 @@ EAPI=5
inherit oasis
DESCRIPTION="jQuery Binding for Eliom."
-HOMEPAGE="jQuery Binding for Eliom."
-SRC_URI="https://github.com/ocsigen/ojquery/archive/${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://github.com/ocsigen/ojquery"
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ SRC_URI=""
+ EGIT_REPO_URI="https://github.com/ocsigen/ojquery"
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/ocsigen/ojquery/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
LICENSE="LGPL-3"
SLOT="0/${PV}"
-KEYWORDS="~amd64"
IUSE=""
RDEPEND="dev-ml/react:=
diff --git a/dev-ml/ojquery/ojquery-9999.ebuild b/dev-ml/ojquery/ojquery-9999.ebuild
index a4f9a1d20424..123a47477ebb 100644
--- a/dev-ml/ojquery/ojquery-9999.ebuild
+++ b/dev-ml/ojquery/ojquery-9999.ebuild
@@ -7,7 +7,7 @@ EAPI=5
inherit oasis
DESCRIPTION="jQuery Binding for Eliom."
-HOMEPAGE="jQuery Binding for Eliom."
+HOMEPAGE="https://github.com/ocsigen/ojquery"
if [ "${PV#9999}" != "${PV}" ] ; then
inherit git-r3