summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Try-Tiny/Try-Tiny-0.220.0.ebuild')
-rw-r--r--dev-perl/Try-Tiny/Try-Tiny-0.220.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-perl/Try-Tiny/Try-Tiny-0.220.0.ebuild b/dev-perl/Try-Tiny/Try-Tiny-0.220.0.ebuild
new file mode 100644
index 000000000000..e2cf52ceca6a
--- /dev/null
+++ b/dev-perl/Try-Tiny/Try-Tiny-0.220.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=DOY
+MODULE_VERSION=0.22
+inherit perl-module
+
+DESCRIPTION="Minimal try/catch with proper localization of $@"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ >=virtual/perl-Exporter-5.570.0
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.300.0
+ test? (
+ dev-perl/Sub-Name
+ >=dev-perl/Capture-Tiny-0.120.0
+ virtual/perl-File-Spec
+ virtual/perl-Test-Simple
+ virtual/perl-if
+ )
+"
+
+SRC_TEST="do parallel"