summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl/Variable-Magic/Variable-Magic-0.580.0.ebuild')
-rw-r--r--dev-perl/Variable-Magic/Variable-Magic-0.580.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/Variable-Magic/Variable-Magic-0.580.0.ebuild b/dev-perl/Variable-Magic/Variable-Magic-0.580.0.ebuild
new file mode 100644
index 000000000000..3c0b405757f5
--- /dev/null
+++ b/dev-perl/Variable-Magic/Variable-Magic-0.580.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=VPIT
+MODULE_VERSION=0.58
+inherit perl-module
+
+DESCRIPTION="Associate user-defined magic to variables from Perl"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86 ~ppc-aix ~x64-macos"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Exporter
+ virtual/perl-XSLoader
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Test-Simple
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+ )
+"
+
+SRC_TEST="do parallel"