summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/XML-AutoWriter/XML-AutoWriter-0.400.0-r1.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/dev-perl/XML-AutoWriter/XML-AutoWriter-0.400.0-r1.ebuild b/dev-perl/XML-AutoWriter/XML-AutoWriter-0.400.0-r1.ebuild
index 63c93f19fb30..77d701623563 100644
--- a/dev-perl/XML-AutoWriter/XML-AutoWriter-0.400.0-r1.ebuild
+++ b/dev-perl/XML-AutoWriter/XML-AutoWriter-0.400.0-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-MODULE_AUTHOR=PERIGRIN
-MODULE_VERSION=0.4
+DIST_AUTHOR=PERIGRIN
+DIST_VERSION=0.4
inherit perl-module
DESCRIPTION="DOCTYPE based XML output"
@@ -17,9 +17,11 @@ IUSE=""
RDEPEND="dev-perl/XML-Parser"
DEPEND="${RDEPEND}"
-SRC_TEST="do"
-
src_prepare() {
sed -i '/^auto_set_repository/d' Makefile.PL || die
+
+ sed -i -e 's/use inc::Module::Install/use lib q[.]; use inc::Module::Install/' Makefile.PL ||
+ die "Can't patch Makefile.PL for 5.26 dot-in-inc"
+
perl-module_src_prepare
}