summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/PEAR-Net_IMAP/Manifest1
-rw-r--r--dev-php/PEAR-Net_IMAP/PEAR-Net_IMAP-1.1.4.ebuild45
-rw-r--r--dev-php/PEAR-Net_IMAP/metadata.xml14
-rw-r--r--dev-php/pecl-event/pecl-event-3.1.4.ebuild4
-rw-r--r--dev-php/pecl-http/Manifest2
-rw-r--r--dev-php/pecl-http/pecl-http-4.2.6.ebuild (renamed from dev-php/pecl-http/pecl-http-4.2.2-r1.ebuild)11
-rw-r--r--dev-php/pecl-raphf/pecl-raphf-2.0.1-r3.ebuild (renamed from dev-php/pecl-raphf/pecl-raphf-2.0.1-r2.ebuild)10
-rw-r--r--dev-php/pecl-redis/pecl-redis-6.1.0.ebuild4
-rw-r--r--dev-php/pecl-ssh2/pecl-ssh2-1.4.1.ebuild4
-rw-r--r--dev-php/pecl-yaz/pecl-yaz-1.2.4-r1.ebuild4
10 files changed, 79 insertions, 20 deletions
diff --git a/dev-php/PEAR-Net_IMAP/Manifest b/dev-php/PEAR-Net_IMAP/Manifest
new file mode 100644
index 000000000000..1fd38cac978c
--- /dev/null
+++ b/dev-php/PEAR-Net_IMAP/Manifest
@@ -0,0 +1 @@
+DIST Net_IMAP-1.1.4.tgz 40723 BLAKE2B 0e6b7bc01301f26464afdee148318549e239c6bb8fc5646f13fc728b0e581ae8c9bc9961e83065138f31df0a81e4ed79794420be4d3a7c43b6bacc619ed672ad SHA512 2747cdb3d7f11dc4e9bc5c531c4c49cbd1b65b0ff71b30f46f06a4ad10aae341c1323a7c4a9ffb4fa3b8694a75cf60fdcb9cf433c765f29e17bd1e86c5fa929d
diff --git a/dev-php/PEAR-Net_IMAP/PEAR-Net_IMAP-1.1.4.ebuild b/dev-php/PEAR-Net_IMAP/PEAR-Net_IMAP-1.1.4.ebuild
new file mode 100644
index 000000000000..345cf489d8c1
--- /dev/null
+++ b/dev-php/PEAR-Net_IMAP/PEAR-Net_IMAP-1.1.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Provides an implementation of the IMAP protocol"
+HOMEPAGE="https://pear.php.net/package/Net_IMAP
+ https://github.com/pear/Net_IMAP"
+SRC_URI="https://pear.php.net/get/${MY_P}.tgz"
+S="${WORKDIR}/${MY_P}"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc64 ~sparc ~x86"
+IUSE="sasl"
+RDEPEND="dev-lang/php:*
+ dev-php/PEAR-Net_Socket
+ dev-php/PEAR-PEAR
+ sasl? ( dev-php/PEAR-Auth_SASL )"
+
+src_install() {
+ insinto /usr/share/php
+ doins -r Net
+ dodoc docs/*
+ insinto /usr/share/php/.packagexml
+ newins "${WORKDIR}/package.xml" "${MY_P}.xml"
+}
+
+pkg_postinst() {
+ # It is not critical to complete so only warn on failure
+ if [[ -f "${EROOT}/usr/share/php/.packagexml/${MY_P}.xml" && \
+ -x "${EROOT}/usr/bin/peardev" ]] ; then
+ "${EROOT}/usr/bin/peardev" install -nrO --force \
+ "${EROOT}/usr/share/php/.packagexml/${MY_P}.xml" 2> /dev/null \
+ || ewarn "Failed to insert package into local PEAR database"
+ fi
+}
+
+pkg_postrm() {
+ if [[ -x "${EROOT}/usr/bin/peardev" ]]; then
+ "${EROOT}/usr/bin/peardev" uninstall -nrO "pear.php.net/${MY_PN}"
+ fi
+}
diff --git a/dev-php/PEAR-Net_IMAP/metadata.xml b/dev-php/PEAR-Net_IMAP/metadata.xml
new file mode 100644
index 000000000000..86cdbad4cb33
--- /dev/null
+++ b/dev-php/PEAR-Net_IMAP/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>mjo@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">pear/Net_IMAP</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-php/pecl-event/pecl-event-3.1.4.ebuild b/dev-php/pecl-event/pecl-event-3.1.4.ebuild
index 8425536a7b47..5357ace6dca6 100644
--- a/dev-php/pecl-event/pecl-event-3.1.4.ebuild
+++ b/dev-php/pecl-event/pecl-event-3.1.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="8"
@@ -17,7 +17,7 @@ DESCRIPTION="PHP wrapper for libevent2"
HOMEPAGE="https://pecl.php.net/package/event"
LICENSE="PHP-3.01"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
IUSE="debug examples +extra +sockets +ssl threads"
DEPEND=">=dev-libs/libevent-2.0.2[ssl?]
ssl? ( dev-libs/openssl:= )"
diff --git a/dev-php/pecl-http/Manifest b/dev-php/pecl-http/Manifest
index c6ecbe7266f4..cd0e425a2ea3 100644
--- a/dev-php/pecl-http/Manifest
+++ b/dev-php/pecl-http/Manifest
@@ -1 +1 @@
-DIST pecl_http-4.2.2.tgz 224436 BLAKE2B 26ef3bb38778f0374938ba3f3bddba37c3a2044c7b9ffe2aacbca2566251d26d37882bf66773b8ed62d46855e8f14ad9b577cdb1ef3db9eba9850c0b30e57284 SHA512 1203367d590c7d80ffe7a21e7ac352ba053e3daeb778bf99e08fc13582e665e1429f850e51e36304bdec15e6646b648f2c444b46fa263e5441d008ac41a00f4b
+DIST pecl_http-4.2.6.tgz 225503 BLAKE2B 834c5a38de2ec5525472fbe3a2c92804e3d471cdbd2f0791990bbde3001a4ba63822e9e4600b1a692f117f4fb941c86a78cd533512b7c5cacdad87f055160cfd SHA512 50c921d11e035281bd55152e449ee47d203c839d654b097fcbc5d6d93faf91a6111817b8a7157715de0af9f15c713974a53a2ab318eddd840bc3a7e6b2b50e11
diff --git a/dev-php/pecl-http/pecl-http-4.2.2-r1.ebuild b/dev-php/pecl-http/pecl-http-4.2.6.ebuild
index 976d95d6c8fa..c37376e61578 100644
--- a/dev-php/pecl-http/pecl-http-4.2.2-r1.ebuild
+++ b/dev-php/pecl-http/pecl-http-4.2.6.ebuild
@@ -9,27 +9,28 @@ PHP_EXT_INI="yes"
PHP_EXT_ZENDEXT="no"
PHP_INI_NAME="50-http"
-USE_PHP="php8-1"
+USE_PHP="php8-1 php8-2 php8-3"
inherit php-ext-pecl-r3
-KEYWORDS="amd64 x86"
-
DESCRIPTION="Extended HTTP Support for PHP"
LICENSE="BSD-2 MIT"
SLOT="8"
+KEYWORDS="amd64 x86"
IUSE="ssl curl_ssl_gnutls +curl_ssl_openssl"
COMMON_DEPEND="app-arch/brotli:=
dev-libs/libevent
- >=dev-php/pecl-raphf-2.0.1:7[php_targets_php8-1(-)?]
+ >=dev-php/pecl-raphf-2.0.1:7[php_targets_php8-1(-)?,php_targets_php8-2(-)?,php_targets_php8-3(-)?]
net-dns/libidn2
sys-libs/zlib
ssl? ( net-misc/curl[ssl,curl_ssl_gnutls(-)=,curl_ssl_openssl(-)=] )
!ssl? ( net-misc/curl[-ssl] )
"
DEPEND="
- php_targets_php8-1? ( ${COMMON_DEPEND} dev-lang/php:8.1[session(-),iconv(-)] )"
+ php_targets_php8-1? ( ${COMMON_DEPEND} dev-lang/php:8.1[session(-),iconv(-)] )
+ php_targets_php8-2? ( ${COMMON_DEPEND} dev-lang/php:8.2[session(-),iconv(-)] )
+ php_targets_php8-3? ( ${COMMON_DEPEND} dev-lang/php:8.3[session(-),iconv(-)] )"
RDEPEND="${DEPEND}"
PHP_EXT_ECONF_ARGS=( --with-http --without-http-shared-deps
diff --git a/dev-php/pecl-raphf/pecl-raphf-2.0.1-r2.ebuild b/dev-php/pecl-raphf/pecl-raphf-2.0.1-r3.ebuild
index 3d7ea2841257..31c27d50de84 100644
--- a/dev-php/pecl-raphf/pecl-raphf-2.0.1-r2.ebuild
+++ b/dev-php/pecl-raphf/pecl-raphf-2.0.1-r3.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI="8"
PHP_EXT_NAME="raphf"
PHP_EXT_INI="yes"
@@ -9,13 +9,11 @@ PHP_EXT_ZENDEXT="no"
PHP_EXT_ECONF_ARGS=""
PHP_INI_NAME="30-${PHP_EXT_NAME}"
-USE_PHP="php8-1"
+USE_PHP="php8-1 php8-2 php8-3"
inherit php-ext-pecl-r3
-KEYWORDS="amd64 x86"
-
DESCRIPTION="A reusable, persistent handle and resource factory API"
LICENSE="BSD-2"
SLOT="7"
-IUSE=""
+KEYWORDS="amd64 x86"
diff --git a/dev-php/pecl-redis/pecl-redis-6.1.0.ebuild b/dev-php/pecl-redis/pecl-redis-6.1.0.ebuild
index 84df442bf7cd..0a58a9f1494f 100644
--- a/dev-php/pecl-redis/pecl-redis-6.1.0.ebuild
+++ b/dev-php/pecl-redis/pecl-redis-6.1.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -15,7 +15,7 @@ inherit php-ext-pecl-r3
DESCRIPTION="PHP extension for interfacing with Redis"
LICENSE="PHP-3.01"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64"
+KEYWORDS="amd64 ~arm ~arm64"
IUSE="igbinary +json lz4 +session zstd"
DEPEND="
diff --git a/dev-php/pecl-ssh2/pecl-ssh2-1.4.1.ebuild b/dev-php/pecl-ssh2/pecl-ssh2-1.4.1.ebuild
index f5d84cb102d4..af6d86acf72a 100644
--- a/dev-php/pecl-ssh2/pecl-ssh2-1.4.1.ebuild
+++ b/dev-php/pecl-ssh2/pecl-ssh2-1.4.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="8"
@@ -13,7 +13,7 @@ DESCRIPTION="PHP bindings for the libssh2 library"
HOMEPAGE="https://pecl.php.net/package/ssh2"
LICENSE="PHP-3.01"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
# Upstream notes say there are errors with gcrypt backend
DEPEND=">=net-libs/libssh2-1.2[-gcrypt]"
RDEPEND="${DEPEND}"
diff --git a/dev-php/pecl-yaz/pecl-yaz-1.2.4-r1.ebuild b/dev-php/pecl-yaz/pecl-yaz-1.2.4-r1.ebuild
index e4d5f45b5344..9a050a4d4890 100644
--- a/dev-php/pecl-yaz/pecl-yaz-1.2.4-r1.ebuild
+++ b/dev-php/pecl-yaz/pecl-yaz-1.2.4-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2024 Gentoo Authors
+# Copyright 1999-2025 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -15,7 +15,7 @@ inherit php-ext-pecl-r3
DESCRIPTION="This extension implements a Z39.50 client for PHP using the YAZ toolkit"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~hppa ~ppc64 ~s390 ~sparc ~x86"
+KEYWORDS="amd64 arm ~hppa ~ppc64 ~s390 ~sparc x86"
RESTRICT="test"
DEPEND=">=dev-libs/yaz-3.0.2:0="