summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-yaml/pecl-yaml-2.0.4.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/dev-php/pecl-yaml/pecl-yaml-2.0.4.ebuild b/dev-php/pecl-yaml/pecl-yaml-2.0.4.ebuild
index 804cd88748e5..3a1a1abfdb9b 100644
--- a/dev-php/pecl-yaml/pecl-yaml-2.0.4.ebuild
+++ b/dev-php/pecl-yaml/pecl-yaml-2.0.4.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
MY_PV="${PV/_rc/RC}"
PHP_EXT_PECL_FILENAME="yaml-${MY_PV}.tgz"
@@ -10,13 +10,13 @@ PHP_EXT_INI="yes"
PHP_EXT_ZENDEXT="no"
DOCS=( CREDITS README )
-USE_PHP="php7-0 php7-1 php7-2 php7-3 php5-6"
+USE_PHP="php7-0 php7-1 php7-2 php7-3 php7-4 php5-6"
inherit php-ext-pecl-r3
S="${WORKDIR}/yaml-${MY_PV}"
PHP_EXT_S="${S}"
-USE_PHP="php7-0 php7-1 php7-2 php7-3"
+USE_PHP="php7-0 php7-1 php7-2 php7-3 php7-4"
KEYWORDS="~amd64 ~x86"
@@ -30,7 +30,7 @@ RDEPEND="${DEPEND} php_targets_php5-6? ( dev-php/pecl-yaml:0[php_targets_php5-6]
PHP_EXT_ECONF_ARGS=""
src_prepare() {
- if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
+ if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-4 ; then
php-ext-source-r3_src_prepare
else
default_src_prepare
@@ -38,7 +38,7 @@ src_prepare() {
}
src_install() {
- if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 ; then
+ if use php_targets_php7-0 || use php_targets_php7-1 || use php_targets_php7-2 || use php_targets_php7-3 || use php_targets_php7-4 ; then
php-ext-pecl-r3_src_install
fi
}