summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/PEAR-Console_Getopt/Manifest1
-rw-r--r--dev-php/PEAR-Console_Getopt/PEAR-Console_Getopt-1.4.3.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-php/PEAR-Console_Getopt/Manifest b/dev-php/PEAR-Console_Getopt/Manifest
index 7785babd7758..508f8fc1e759 100644
--- a/dev-php/PEAR-Console_Getopt/Manifest
+++ b/dev-php/PEAR-Console_Getopt/Manifest
@@ -1 +1,2 @@
DIST Console_Getopt-1.4.1.tgz 5580 BLAKE2B 514d44cfd2bb7c8bcda49df2b6ba4dafc77184557f58f52c02c6a136e335639e65b7c10f5659dad9d7a87e946d60947121cb5f35a72b6d29fbb3efa3e535283b SHA512 cbf12a72b33424935f019b17ae8fa55289eae77d3845dcfcbbc1c47b71111992d2c0eb837b0f262ce644809c3cc06ad0c2bb04aa1b6ec89a1e3122f327114dbd
+DIST Console_Getopt-1.4.3.tgz 5789 BLAKE2B 641432105696e93160fd6a3ade4ee8c1bd7780cc502668266485d8c747fc8ceb97ce70ebdab8f61a739a4bf8267bfc936f0c9fd51b408add680a2288d49e0412 SHA512 7803e063576e9dac6833064b5a1479d22ca31c2a8ef8036ae530271e4e824fedb94e54d63266be8929f90f8df745b3ada7185dc98319b331f8dc5e9cac5445a0
diff --git a/dev-php/PEAR-Console_Getopt/PEAR-Console_Getopt-1.4.3.ebuild b/dev-php/PEAR-Console_Getopt/PEAR-Console_Getopt-1.4.3.ebuild
new file mode 100644
index 000000000000..130680148c73
--- /dev/null
+++ b/dev-php/PEAR-Console_Getopt/PEAR-Console_Getopt-1.4.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN/PEAR-/}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Command-line option parser"
+HOMEPAGE="https://pear.php.net/package/Console_Getopt"
+SRC_URI="https://pear.php.net/get/${MY_P}.tgz"
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-lang/php:*"
+PDEPEND="dev-php/PEAR-PEAR"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ insinto /usr/share/php
+ doins -r Console
+}