summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/CacheControl/CacheControl-0.11.5.ebuild')
-rw-r--r--dev-python/CacheControl/CacheControl-0.11.5.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/CacheControl/CacheControl-0.11.5.ebuild b/dev-python/CacheControl/CacheControl-0.11.5.ebuild
deleted file mode 100644
index a09f14fac0d4..000000000000
--- a/dev-python/CacheControl/CacheControl-0.11.5.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python3_6 pypy3 )
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="The httplib2 caching algorithms packaged up for use with requests"
-HOMEPAGE="https://github.com/ionrock/cachecontrol https://pypi.org/project/cachecontrol/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86"
-IUSE="test"
-
-RDEPEND="
- dev-python/requests[${PYTHON_USEDEP}]
- >=dev-python/lockfile-0.9[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-
-# Not included
-RESTRICT=test
-
-python_test() {
- py.test -v -v || die
-}
-
-pkg_postinst() {
- optfeature "Redis based caches" dev-python/redis-py
-}