summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/amqplib/amqplib-1.0.2-r1.ebuild')
-rw-r--r--dev-python/amqplib/amqplib-1.0.2-r1.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-python/amqplib/amqplib-1.0.2-r1.ebuild b/dev-python/amqplib/amqplib-1.0.2-r1.ebuild
deleted file mode 100644
index d8df30715207..000000000000
--- a/dev-python/amqplib/amqplib-1.0.2-r1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python client for the Advanced Message Queuing Procotol (AMQP)"
-HOMEPAGE="https://barryp.org/software/py-amqplib/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tgz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="examples extras test"
-RESTRICT="!test? ( test )"
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.6.1_disable_socket_tests.patch"
- "${FILESDIR}/${P}-unicode_tests_py3.patch"
-)
-
-python_test() {
- "${PYTHON}" tests/client_0_8/run_all.py \
- || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- dodoc -r docs/.
- if use examples; then
- docinto examples
- dodoc -r demo/.
- fi
- if use extras; then
- insinto /usr/share/${PF}
- doins -r extras
- fi
-}