summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/cffi/cffi-1.2.1-r1.ebuild')
-rw-r--r--dev-python/cffi/cffi-1.2.1-r1.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-python/cffi/cffi-1.2.1-r1.ebuild b/dev-python/cffi/cffi-1.2.1-r1.ebuild
deleted file mode 100644
index e4240734ea85..000000000000
--- a/dev-python/cffi/cffi-1.2.1-r1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-# DO NOT ADD pypy to PYTHON_COMPAT
-# pypy bundles a modified version of cffi. Use python_gen_cond_dep instead.
-PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
-
-inherit distutils-r1
-
-DESCRIPTION="Foreign Function Interface for Python calling C code"
-HOMEPAGE="http://cffi.readthedocs.org/ https://pypi.python.org/pypi/cffi"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris"
-IUSE="doc"
-
-RDEPEND="
- virtual/libffi
- dev-python/pycparser[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}"
-
-# Avoid race on _configtest.c (distutils/command/config.py:_gen_temp_sourcefile)
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_compile_all() {
- use doc && emake -C doc html
-}
-
-python_test() {
- py.test -x -v --ignore testing/test_zintegration.py c/ testing/ || die "Testing failed with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/build/html/. )
- distutils-r1_python_install_all
-}